Ask Your Question
0

Error while building opencv from source on Windows

asked 2014-09-03 00:48:38 -0500

Rich gravatar image

Here is my setup.

Attached is the build log.

To pass upload it was renamed to png. Must be renamed from png to txt to view it: C:\fakepath\build.png

Here is the first build error:

7>C:/workspace/opencv/opencv/modules/core/src/cuda/gpu_mat.cu(51): fatal error C1083: Cannot open include file: 'opencv2/core/cuda.hpp': No such file or directory 5> jerror.c 7>CUSTOMBUILD : nvcc warning : The 'compute_11', 'compute_12', 'compute_13', 'sm_11', 'sm_12', and 'sm_13' architectures are deprecated, and may be removed in a future release. 7>
7> CMake Error at cuda_compile_generated_gpu_mat.cu.obj.cmake:206 (message): 7> Error generating 7> C:/workspace/opencv/build/modules/core/CMakeFiles/cuda_compile.dir/src/cuda/Debug/cuda_compile_generated_gpu_mat.cu.obj

Observations:

The cuda.hpp file exists on my disk at this location: C:\workspace\opencv\opencv\modules\core\include\opencv2\core\cuda.hpp

Seems that all .cu files fail compilation because they cannot find header files. All .cpp files compile just fine. The project file have the correct include path

Questions / recommendations

  • Did someone made it work on Windows 8 with Visual Studio 2012?
  • Is it correct to use the latest code from git repository? If not any tag recommended?
  • What am I missing? Any input or suggestions are welcome.

Thank you C:\fakepath\build.png

edit retag flag offensive close merge delete

Comments

could you just paste the build log above ?

berak gravatar imageberak ( 2014-09-03 00:52:00 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-09-03 01:37:58 -0500

jestshen gravatar image

I have built up OpenCV on windows8 VS2012. I guess your problem must be some error on your include file direction.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2014-09-03 00:48:38 -0500

Seen: 938 times

Last updated: Sep 03 '14