Ask Your Question

findHomography gives an error libstdc++-6.dll entry point missing

asked 2012-07-16 05:58:44 -0500

genetica gravatar image

updated 2019-12-09 08:14:09 -0500

Akhil Patel gravatar image

Good day

When using the function findHomography( obj, scene, CV_RANSAC ) the following error occur:

"The procedure entry point __ZNSt8__detail15_List_node_base11_M_transferEPS0_S1_ could not be located in the dynamic link library libstdc++-6.dll."

I am running Windows7, MinGW, Codeblocks and Opencv2.4 and using the code:

Except for the include which I use:

#include "stdio.h"
#include "iostream"
#include "opencv2/core/core.hpp"
#include "opencv2/highgui/highgui.hpp"
#include "opencv2/nonfree/features2d.hpp"
#include "opencv2/nonfree/nonfree.hpp"
#include "opencv2/legacy/legacy.hpp"

if I use the include in the code the SurfFeatureDetector becomes undeclared with various other functions.


edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted

answered 2012-07-16 07:58:58 -0500

genetica gravatar image

Updated from MINGW32 version 3.17 to MINGW32 version 3.18 seems to have solved the problem.

Still unsure what the cause was, if someone can maybe point out a possible cause?

edit flag offensive delete link more

answered 2012-10-10 01:44:08 -0500

anr gravatar image

How do you update the version of MinGW I used code::block and i get the same error when i ran one of opencv sample Thanks

edit flag offensive delete link more


you can run "mingw-get update" in cmd

genetica gravatar imagegenetica ( 2012-11-07 08:23:29 -0500 )edit
Login/Signup to Answer

Question Tools


Asked: 2012-07-16 05:58:44 -0500

Seen: 982 times

Last updated: Oct 10 '12