Ask Your Question
0

help building opencv with CUDA Jetson TK1

asked 2014-07-29 21:45:34 -0500

doc gravatar image

how do I fix this error? I was close to getting this built.

cmake -D CMAKE_BUILD_TYPE=RELEASE -D CMAKE_INSTALL_PREFIX=/usr/local ..

make stops here:

[ 4%] Building NVCC (Device) object modules/core/CMakeFiles/cuda_compile.dir/src/cuda/./cuda_compile_generated_gpu_mat.cu.o nvcc fatal : Unsupported gpu architecture 'compute_11' CMake Error at cuda_compile_generated_gpu_mat.cu.o.cmake:208 (message): Error generating /home/ubuntu/opencv/release/modules/core/CMakeFiles/cuda_compile.dir/src/cuda/./cuda_compile_generated_gpu_mat.cu.o

make[2]: * [modules/core/CMakeFiles/cuda_compile.dir/src/cuda/./cuda_compile_generated_gpu_mat.cu.o] Error 1 make[1]: [modules/core/CMakeFiles/opencv_core.dir/all] Error 2 make: ** [all] Error 2

edit retag flag offensive close merge delete

Comments

You have to manually specify your compute capability, which should be 3.0 since it is the Kepler architecture which I can read from the specs. Just add the following command to your CMAKE arguments:

 -D CUDA_ARCH_BIN="3.0"

And the other architectures should be completely ignored.

StevenPuttemans gravatar imageStevenPuttemans ( 2014-07-30 04:32:18 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-03-07 06:50:17 -0500

TechWizard gravatar image

I got the same error at first. After adding the following cmake cache entries, the compilation of OpenCV 3.0.0-beta was successful.

-D CUDA_ARCH_BIN=3.2
-D CUDA_ARCH_PTX=3.2

Note: I have Linux for Tegra R21.3 with CUDA 6.5 and ffmpeg-2.5.4* installed on my Jetson TK1 dev-board.

*Don't forget to compile with the --enable-shared config option!

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2014-07-29 21:45:34 -0500

Seen: 3,522 times

Last updated: Jul 29 '14