OpenCV with IAR

asked 2014-07-17 22:18:07 -0500

updated 2014-07-18 00:34:39 -0500

berak gravatar image

Hi there,

I am trying to add OpenCV libraries to IAR environment.

So far, I haven't been able to find a comprehensive documentation on how to do that. I've been looking at different documents and tutorials trying to grasp the concept of OpenCV and how to get started with it. So far, the only option that seems viable to me is to use CMake to generate libraries for IAR.

What I've tried to do so far was I followed the "Installation for Windows" tutorial, except I did not install 3rd party libraries and for step 7 I tried to configure CMake to use a toolchain file for IAR - IAR.cmake. CMake could not build and gave me an error message:

CMake Error at C:/Program Files (x86)/CMake/share/cmake-3.0/Modules/Compiler/IAR.cmake:41 (message): The IAR compiler for this architecture is not yet supported by CMake. Please go to http://www.cmake.org/Bug and enter a feature request there.

Call Stack (most recent call first): C:/Program Files (x86)/CMake/share/cmake-3.0/Modules/CMakeDetermineSystem.cmake:98 (include) CMakeLists.txt:56 (project)

CMake Error: Could not find cmake module file: D:/KN/iar/opencv/CMakeFiles/3.0.0/CMakeCXXCompiler.cmake CMake Error: Could not find cmake module file: D:/KN/iar/opencv/CMakeFiles/3.0.0/CMakeCCompiler.cmake CMake Error at CMakeLists.txt:56 (project):

No CMAKE_CXX_COMPILER could be found. CMake Error at CMakeLists.txt:56 (project): No CMAKE_C_COMPILER could be found.

I am not sure if I followed a correct procedure.

Can anybody, please, layout a correct procedure to generate libraries for a development environment such as IAR(a generic procedure would be helpful too)?

Any suggestions would be appreciated.

Regrads, Kaisar

edit retag flag offensive close merge delete

Comments

So I tried to configure CMake for cross compiling by entering options for cross compiling such as CMAKE_SYSTEM_NAME, CMAKE_C_COMPILER etc. in cmake-gui.

When I try to complete configuration I get this error message:

CMake Error at cmake/FindCUDA.cmake:763 (if): if given arguments:

"CUDA_VERSION" "VERSION_GREATER" "5.0" "AND" "CMAKE_CROSSCOMPILING" "AND" "MATCHES" "arm"

Unknown arguments specifiedCall Stack (most recent call first):cmake/OpenCVDetectCUDA.cmake:26 (find_package)cmake/OpenCVFindLibsPerf.cmake:24 (include)CMakeLists.txt:468 (include)

Has anyone come across such an error? I couldn't find anyone with a similar problem

NKaisar gravatar imageNKaisar ( 2014-07-18 04:02:46 -0500 )edit