gpu calib3d does not work

asked 2014-07-14 18:22:03 -0500

Krzych gravatar image

I am trying to use GPU features of OpenCV for stereo vision, but GPU features of calib3d module does not work on my machine. I have run samples for GPU and the great majority of tests passed (circa 25k), but some has failed (about 370). Most of the tests failed because result matrix was empty. So did all calib3d tests. I am using OpenCV 2.4.9 and CUDA 5.5 but my graphic card supports only CUDA 3.0 or 3.5.

Does anybody know what may be the problem?

edit retag flag offensive close merge delete

Comments

There can be several problems 1. You built OpenCV for the wrong CUDA architecture at first which is stupid since newer architectures use optimizations that your card doesn't support. So there they crash. 2. Secondly, be aware that you actually have to built opencv yourself since there are no prebuilt CUDA support libs for 2.4.9 so installing the correct CUDA version on your system should basically do the trick.

StevenPuttemans gravatar imageStevenPuttemans ( 2014-07-15 03:03:39 -0500 )edit

I did build my own OpenCV. From what I can tell from CMake log it was prepared to use only features from CUDA up to 3.5 (I belive this is my card CUDA version). Also most of the test (more then 25500 of them) did pass successfully and only 370 failed. This suggests CUDA does work, also I have previously used CUDA mysefl with 5.5 toolkit. It does not look like version of the toolkit is the problem.

Krzych gravatar imageKrzych ( 2014-07-15 07:31:35 -0500 )edit

Then the only solution will be to provide the tests that are not working and indicate what goes wrong...

StevenPuttemans gravatar imageStevenPuttemans ( 2014-07-15 07:38:25 -0500 )edit

I can post the whole list.

Krzych gravatar imageKrzych ( 2014-07-15 07:45:39 -0500 )edit

Then please do so!

StevenPuttemans gravatar imageStevenPuttemans ( 2014-07-15 07:57:10 -0500 )edit

The list is too long to paste it here so I have uploaded it to dropbox https://www.dropbox.com/s/xbhpmcu712ct8j7/CUDA%20failed%20tests.txt

I have included HW report from the begining of the test.

Krzych gravatar imageKrzych ( 2014-07-15 08:10:19 -0500 )edit