Ask Your Question
0

link opencv 2.4.2 with QT

asked 2012-10-19 11:59:44 -0500

Jevin gravatar image

Hi,

i'm trying to link Opencv 2.4.2 with QT

but from the blog that i have come along they tell to use cmake

but Cmake does not work

++++

can anyone help me ??? how to use opencv 2.4.2 with QT

thanks in advance

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2012-10-20 21:17:55 -0500

beowulf gravatar image

Are complicated steps, but nothing impossible.

This tutorial will help you:

http://www.laganiere.name/opencvCookbook/chap1s1_2.shtml

and that video:

http://www.youtube.com/watch?v=dgcXYQijV6c

edit flag offensive delete link more
0

answered 2013-03-05 21:27:37 -0500

Jevin gravatar image

I found out this video to be more interesting to make opencv work with QT

http://www.youtube.com/watch?v=0ONxIy8itRA

More wideos about opencv/emgucv - almost same can be found here:: http://www.youtube.com/user/18F4550videos?feature=watch

thanks for the answers anyway.

edit flag offensive delete link more
0

answered 2012-10-20 20:36:21 -0500

mgb gravatar image

Do you mean use the Qt enhanced high gui window or use opencv in your Qt app?

If you are programming with Qt - simply add the openCV include and lib dirs, include the opencv library files as with any other and make sure the opencv dll's are in the path.
The opencv image format is directly compatible with QImage's BGR.

If you want openCV to use the Qt version of highgui and none of the downloads are suitable then you need to build opencv from source. This depends on your OS but there are walkthroughs on the docs.opencv.org site

edit flag offensive delete link more

Comments

Well, I have a lot of problems trying to use OpenCV 2.4.5 with QT 5.0.2 with Windos 7, and I solved it building opencv from source. The links are the tutorial from Lagarniere mentioned above and this other tutorial.

http://stackoverflow.com/questions/14919186/qt-creator-5-0-1-with-opencv-2-3-4-on-windows/15268560#15268560

I answer it because I can't use openCV2.4.5 simply adding the openCV include and lib dirs, there are some weird problem with the dependencies and the version of MinGW. And I only had the PATH variable of my building libraries.

When I was trying to fix it, I haven't found out some answer like this so I write this answer if someone is having the same problems.

Regards.

ducalru gravatar imageducalru ( 2013-06-27 04:52:59 -0500 )edit
Login/Signup to Answer

Question Tools

Stats

Asked: 2012-10-19 11:59:44 -0500

Seen: 2,147 times

Last updated: Mar 05 '13