Ask Your Question

[ 35%] fatal error: too many errors emitted, stopping now [-ferror-limit=]

asked 2014-04-24 10:12:12 -0500

lobsterman gravatar image

updated 2014-04-25 03:41:51 -0500

Hi all, I am attempting a compile of opencv-2.4.9 unix on mac osx 10.9.2. downloaded from sourceforge, it stops when it hits the maximum of these booboos

/Users/rhuber/Documents/C-Java/opencv/opencv-2.4.9/modules/highgui/src/ffmpeg_codecs.hpp:126:7: error: 
      use of undeclared identifier 'CODEC_ID_MPEG4'; did you mean
    { CODEC_ID_MPEG4, MKTAG(0x04, 0, 0, 0) }, /* some broken avi use this */
/usr/local/include/libavcodec/avcodec.h:123:5: note: 'AV_CODEC_ID_MPEG4'
      declared here
fatal error: too many errors emitted, stopping now [-ferror-limit=]

the same problem occurs when i go back to the earlier versions OpenCV-2.4.3 and opencv- i am thinking it is somehow related to having a version of ffmpeg installed somewhere that is either too new or too old for opencv. any suggestions on how i can fix it?

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted

answered 2014-11-09 13:34:07 -0500

lobsterman gravatar image

updated 2014-11-09 13:39:11 -0500

i am answering my own question in case someone else gets here with a similar problem. i had tried to install opencv first with homebrew, then ran into issues and switched to macports. had to go back into homebrew and first uninstall ffmpeg, then start over and install opencv in macports ... voila, and all worked like a charm

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2014-04-24 10:12:12 -0500

Seen: 2,679 times

Last updated: Nov 09 '14