Ask Your Question
0

VideoReader_GPU not available, but built with NVCUVID?

asked 2014-03-14 10:05:25 -0500

crackwitz gravatar image

updated 2014-03-14 10:41:11 -0500

I've built OpenCV 2.4.8 with CUDA 5.5 using Visual studio 2012. Building code to use it seems to work too. gpu::getCudaEnabledDeviceCount() reports 1.

However, when I try to initialize a VideoReader_GPU, I get this runtime error:

OpenCV Error: The function/feature is not implemented (The called functionality is disabled for current build or platfom) in throw_nogpu, file P:/opencv-2.4.8/sources/modules/gpu/src/precomp.hpp, line 131

CMake reported availability and successful build of NVCUVID. How can I verify that? What's going on?

EDIT: I've just perused the sources I downloaded... #if !defined(HAVE_CUDA) || defined(CUDA_DISABLER) || !defined(HAVE_NVCUVID) should be responsible. I will try to figure out which define is causing this...

EDIT: I've changed that line to remove CUDA_DISABLER. that seems to have worked... since both HAVE_NVCUVID and HAVE_CUDA are reported to be true/defined by CMake.

What is CUDA_DISABLER?

edit retag flag offensive close merge delete

Comments

Hi! I am having the same problem. Where did you edit and removed the CUDA_DISABLER line? I found it in video_reader and video_writer. I onnly disabled it in video_reader. Did you find out why is that condition for?

Thanks for your help!

D!

Dmelladom gravatar imageDmelladom ( 2015-01-07 10:46:56 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-02-23 03:40:58 -0500

zshn25 gravatar image

Try updating your Nvidia device drivers. Worked for me

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2014-03-14 10:05:25 -0500

Seen: 2,369 times

Last updated: Feb 23 '16