Ask Your Question

Error in classifier?

asked 2014-03-06 13:44:49 -0600

Rolo gravatar image

Hi everyone,

I've built a classifier file, and I am getting the following error when attempting to use it (to detect a custom image/shape).

OpenCV Error: Unspecified error (The node does not represent a user object (unknown type?)) in cvRead, file /tmp/opencv/opencv-2.4.7/modules/core/src/persistence.cpp, line 4996 terminate called after throwing an instance of 'cv::Exception' what(): /tmp/opencv/opencv-2.4.7/modules/core/src/persistence.cpp:4996: error: (-2) The node does not represent a user object (unknown type?) in function cvRead

I know that the original haarcascade_frontalface_alt2.xml file I used during testing still works well, so not sure what the differences might be that are leading to the above error.

Any direction you could point me in would be greatly appreciated :)


edit retag flag offensive close merge delete


I should mention that this classifier was made using opencv_traincascade. I am going to attempt to rebuild it using opencv_haartraining.

Rolo gravatar imageRolo ( 2014-03-06 14:18:48 -0600 )edit

2 answers

Sort by ยป oldest newest most voted

answered 2015-12-01 10:16:24 -0600

martykube gravatar image

updated 2015-12-01 10:34:29 -0600

I'm pretty sure this is a bug.

I've posted a minimal example which reproduces the error.

The issue is present in 3.0.0-dev. The prior bug report looks like is was in 2.4.

edit flag offensive delete link more



Regarding your comment below, the performance app is not valid in 3.0. Please, read this post:

LorenaGdL gravatar imageLorenaGdL ( 2015-12-01 10:28:02 -0600 )edit

Okay, got it, thanks!

How about removing opencv_performance in 3.0.0-dev so it does not trick anyone else?

martykube gravatar imagemartykube ( 2015-12-01 13:13:29 -0600 )edit

Well that was my initial goal, but I would rather have the time and place to update it to be usefull again with master version.

StevenPuttemans gravatar imageStevenPuttemans ( 2015-12-02 04:10:13 -0600 )edit

Oh BTW, seems we already removed it...

StevenPuttemans gravatar imageStevenPuttemans ( 2015-12-02 04:32:59 -0600 )edit

You're totally correct, I don't see opencv_performance in the 3.0.0-dev branch. opencv_performance is installed on my system. My host must have some mixed up versions installed. Thanks for the answers!

martykube gravatar imagemartykube ( 2015-12-02 21:30:40 -0600 )edit

You are welcome!

StevenPuttemans gravatar imageStevenPuttemans ( 2015-12-03 02:00:41 -0600 )edit

answered 2014-03-13 13:04:30 -0600

Rolo gravatar image

This error was actually occurring because of an error in the cascade file. The method I was using for detection required some specific changes. Closing :)

edit flag offensive delete link more


Could you please elaborate a little? :) I'm running in to the exact same issue and not sure what else to try.

duskstriker gravatar imageduskstriker ( 2015-01-13 18:10:59 -0600 )edit

I've also run into the same issue with with OpenCV 3.0.

I trained a cascade classifier with opencv_traincascade and then saw the exception when I ran opencv_performance to evaluate the classifier.

I tried following this bug report. Didn't seem to work for me. And the issue is closed...

martykube gravatar imagemartykube ( 2015-11-30 18:48:42 -0600 )edit

Question Tools

1 follower


Asked: 2014-03-06 13:44:49 -0600

Seen: 1,574 times

Last updated: Dec 01 '15