Can't link libs

asked 2014-02-24 08:23:07 -0500

updated 2014-02-24 08:42:15 -0500

berak gravatar image

I've been trying to get opencv running on my note for a school project for a while now, but it just don't work.
I tried MinGW, Code::Blocks, Dev-C and Netbeans, but every single IDE or compiler I use ends up with the same problem: I can get to the Headers, the functions even shows up in Ctrl+Space tips on some IDEs, but it always got me a problem of "undefined reference", even though I linked all of the libs in the IDE's linker, set up the windows path, and, in case of MinGW, linked manually everything.
I'm using the latest build, 2.4.8, the v10 build now, but tried the v12 too.
I tried compiling the source code with cmake, but it returns me an empty bin and lib folders in the output.
In despair, I even tried dual-booting Ubuntu on my note, but the W8 BIOS-hijacking install crashes when Ubuntu boots. Also tried running a virtual machine with Ubuntu, but it runs too slow to be useable.

I don't know what to do anymore ._.

edit retag flag offensive close merge delete

Comments

you can't use the vs libs with mingw. (full-stop)

so, either ditch mingw and get vs express (the free version) ,

or fight your way through building opencv with cmake/mingw

berak gravatar imageberak ( 2014-02-24 08:41:08 -0500 )edit