Ask Your Question
0

OpenCV 2.4.8 build for Visual Studio 2005

asked 2014-02-20 19:41:52 -0500

PeeVee gravatar image

I was wondering if anyone has a working build of a recent version of OpenCV for Visual Studio 2005. I tried to do it myself from the source using the instructions in http://sathyakumar-spark.blogspot.com/2011/10/opencv-on-windows-and-visual-studio.html

It installs fine, after a few minor tweaks but then when I try to run a simple program to read an image using imread, it cannot read the image (returns null in data). Any idea what could be wrong? Or does anyone already have a working version?

Thanks!

edit retag flag offensive close merge delete

Comments

try :

cout << cv::getBuildInformation() << endl;

might be , that you missed to compile the jpeg / png libs, and that now it can' topen it at runtime

berak gravatar imageberak ( 2014-02-21 02:51:12 -0500 )edit

That's interesting. cout << cv::getBuildInformation() << endl; prints garbage from my simple program. However, when I add the line to test_drawing.cpp in the opencv_test_highgui project, it does return valid information which shows that the jpeg/png libs are built. opencv_test_highgui doesn't use the dlls though, so I guess there is something wrong with the dlls I have built. I don't have enough experience to figure out what it could be. I'm on a Win7 64-bit machine but I'm using the x86 compile, by the way.

PeeVee gravatar imagePeeVee ( 2014-02-21 11:34:41 -0500 )edit
1

Fixed. It turned out I had the vc10/bin directory in my path from an earlier install, so it was trying to use the wrong dlls (sigh).

PeeVee gravatar imagePeeVee ( 2014-02-21 16:23:16 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-10-31 06:53:41 -0500

Hi, can you explain the steps you had done for getting the Opencv 2.4.8 run with VS2005.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2014-02-20 19:41:52 -0500

Seen: 1,453 times

Last updated: Oct 31 '14