Ask Your Question
1

Stitching module's strange behavior (Part I)

asked 2012-10-01 04:59:10 -0500

zenberg gravatar image

updated 2012-10-04 01:56:07 -0500

I came across a very strange behavior of the Stitching module.
Please read the whole question to understand the details.


I'm tried to stitch two images named "_pano1.jpg" and "4.jpg" with "match_conf = 0.3".

Here's the debugging output information:

Features in image #1: 853
Features in image #2: 370
Finding features, time: 0.696868 sec
Pairwise matching
1->2 matches: 44
1->2 & 2->1 matches: 67
.Pairwise matching, time: 0.0538355 sec
Removed some images, because can't match them or there are too similar images: (2).
Try to decrease --match_conf value and/or check if you're stitching duplicates.
Need more images


Then I tried to change the value to "match_conf = 0.1". Here's the output after that:

Finding features...
Features in image #1: 853
Features in image #2: 370
Finding features, time: 0.716048 sec
Pairwise matching
1->2 matches: 284
1->2 & 2->1 matches: 384
.Pairwise matching, time: 0.104792 sec
Removed some images, because can't match them or there are too similar images: (2).
Try to decrease --match_conf value and/or check if you're stitching duplicates.
Need more images


At the same time when I'm trying to stitch 3.jpg and 4.jpg with "match_conf = 0.3" the output looks like this:

Finding features...
Features in image #1: 441
Features in image #2: 474
Finding features, time: 0.697173 sec
Pairwise matching
1->2 matches: 62
1->2 & 2->1 matches: 90


So the module stitches them successfully, but if I try to change the value to "match_conf = 0.1", then it tells me that it can't stitch 3.jpg and 4.jpg:

Finding features...
Features in image #1: 441
Features in image #2: 474
Finding features, time: 0.780463 sec
Pairwise matching
1->2 matches: 198
1->2 & 2->1 matches: 335
.Pairwise matching, time: 0.103776 sec
Removed some images, because can't match them or there are too similar images: (2).
Try to decrease --match_conf value and/or check if you're stitching duplicates.
Need more images



~ Why _pano1.jpg and 4.jpg don't stitch no matter what's the value of "match_conf" even though 3.jpg and _pano1.jpg basically contain the same information for stitching with 4.jpg?

~ Why it tells me that it can't stitch 3.jpg and 4.jpg after lowering the "match_conf" value?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2012-10-02 05:48:01 -0500

Alexey Spizhevoy gravatar image

updated 2012-10-02 05:57:25 -0500

Hi,

Internally, in the stitching module it's assumed that an input image is a photo from camera (it's used for camera parameters estimation). The assumption is false for _pano1.jpg as it's not a photo, but a few transformed images stitched.

Too low match confidence means that all (or almost) matches will be classified as good ones. But when all matches are good the method decides that the images are too similar and doesn't stitch them. It's reasonable, for instance, when a camera is fixed and there is a small moving object. In such case almost all matches are good, but it's better not to stitch two images, and take only one as output.

edit flag offensive delete link more

Comments

I posted a couple of related questions in this new thread: http://answers.opencv.org/question/2827/stitching-modules-strange-behavior-part-ii/

Can you please me with those?

zenberg gravatar imagezenberg ( 2012-10-04 01:54:09 -0500 )edit

Could I get some help on a related question on this thread: http://answers.opencv.org/question/19...

as11 gravatar imageas11 ( 2018-07-24 15:22:56 -0500 )edit

@as11 too old post to get help

LBerger gravatar imageLBerger ( 2018-07-24 15:29:03 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2012-10-01 04:59:10 -0500

Seen: 1,236 times

Last updated: Oct 04 '12