Ask Your Question
0

What Android 4.1.3 or newer device did you use to test OpenCV 2.4.7?

asked 2013-12-26 12:42:43 -0500

IZ73 gravatar image

I was hoping to use my new Samsung Galaxy S4 I got from Verizon (running Android 4.3) to test the latest OpenCV. Unfortunately, after discovering this problem, I probably need to use a different device with a different version of Android. So this question is a survey of sorts: if you were able to run OpenCV 2.4.7 on a device running Android 4.1.3 or newer, what device did you use? Thx

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2013-12-26 23:02:14 -0500

linuggz gravatar image

it was updated in opencv-android-2.4.8 a few days ago so it works on my verizon galaxy s4 with 4.3

i was able to get it working by installing alexsander's apk posted in a forum but should be in 2.4.8

edit flag offensive delete link more

Comments

I've post pre-release developers build. Official OpenCV 2.4.8 will be published in a day or two. Use it instead.

Alexander Smorkalov gravatar imageAlexander Smorkalov ( 2013-12-26 23:58:19 -0500 )edit

Alexander, do you happen to know what was the cause of the problem described in my previous posting (http://answers.opencv.org/question/25820/trying-to-run-opencv-samples-on-samsung-galaxy-s4/)? Thx!

IZ73 gravatar imageIZ73 ( 2013-12-27 12:28:30 -0500 )edit

The problem was cased some issue in private Tegra optimizations. Right now, the issue has been fixed and tested on several Samsung devices with Android 4.3.

Alexander Smorkalov gravatar imageAlexander Smorkalov ( 2013-12-29 05:39:05 -0500 )edit
0

answered 2013-12-29 05:36:26 -0500

OpenCV4Android 2.4.8 SDK has been already published. You can install fixed Manager apks from SDK or beta testing package from Google Play. OpenCV team uses this feature to publish new packages. The new version of Manager is published as beta for developers first. If there is no issues, we publish it in production in a week or two. It is done to decrease impact of any regressions for end application users.

edit flag offensive delete link more

Comments

I just downloaded 2.4.8, loaded it into Eclipse, changed Project Build Target to Android 4.3 (not Google APIs 4.3 -- not sure what the difference is) in all the projects (Library, Samples, Tutorials) and tried running it on my S4. Specifically, tried 15-puzzle and face detection. Same result as before: black screen, although I can access the individual sample menus. I am not seeing anything suspicious in logcat or in console output. Any suggestions on how to figure out why it's not working? Thx

IZ73 gravatar imageIZ73 ( 2014-01-07 17:04:44 -0500 )edit

Do you install OpenCV Manager from SDK? You need to use OpenCV Manager 2.16.

Alexander Smorkalov gravatar imageAlexander Smorkalov ( 2014-01-09 23:59:59 -0500 )edit

It worked after I updated the manager. Thanks!

IZ73 gravatar imageIZ73 ( 2014-01-12 11:56:26 -0500 )edit
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-12-26 12:42:43 -0500

Seen: 164 times

Last updated: Dec 29 '13