Ask Your Question
1

Galaxy S4 (Android 4.3) UnsatisfiedLinkError - Where are the libraries?

asked 2013-11-27 09:33:54 -0500

Linke Seitentasche gravatar image

updated 2013-11-27 09:36:05 -0500

Hi

I got my new Samsung Galaxy S4 with Android 4.3. When I try to run my OpenCV app, I get this error on instantiating a Mat():

11-27 16:25:37.298: W/dalvikvm(26236): No implementation found for native Lorg/opencv/core/Mat;.n_Mat:()J

This is how I initialize OpenCV:

boolean ret = OpenCVLoader.initAsync(OpenCVLoader.OPENCV_VERSION_2_4_6, this,
            mLoaderCallback);

Ret value is true. The mLoaderCallback is never called!

This is what OpenCV manager looks like:

image description

There are no installed packages, I think this is not correct. I tried installing a package I found on the Play store but it did not show up under installed packages.

Any suggestions?

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
2

answered 2013-11-27 13:10:47 -0500

It looks like some bug inside OpenCV Manager or some incompatibility with Android 4.3. I've created ticket on bug tracker.

edit flag offensive delete link more

Comments

Thanks a lot!

Linke Seitentasche gravatar imageLinke Seitentasche ( 2013-11-27 13:12:58 -0500 )edit
1

answered 2013-12-24 05:59:34 -0500

It looks like I've fixed the issue. Please check that the solution works on your device. Install the Manager apk and try any OpenCV sample app with the Manager. Please, do it ASAP. OpenCV 2.4.8 will be released in a few days. We need respond from you. Package is here

edit flag offensive delete link more
0

answered 2013-12-26 23:03:51 -0500

linuggz gravatar image

updated 2013-12-26 23:04:24 -0500

This has fixed it for me. thanks Alexander!

Chris

edit flag offensive delete link more

Comments

can u please share your solution

userfacerecognition gravatar imageuserfacerecognition ( 2015-03-03 02:44:48 -0500 )edit

Question Tools

Stats

Asked: 2013-11-27 09:33:54 -0500

Seen: 1,286 times

Last updated: Dec 26 '13