Ask Your Question
0

trouble launching app with opencv 2.4.7 on IOS

asked 2013-11-13 01:14:05 -0500

nakano gravatar image

Hello everyone,

I've just downloaded the openCV 2.4.7 for iOS and when I try to launch my application, it crash during application launch if the iOS version is 6.X (works fine on iOS7).

Here is the error I get when I try to launch it using iOS6.X :

dyld: lazy symbol binding failed: Symbol not found: ___sincos_stret Referenced from: /var/mobile/Applications/49869F6C-A31E-4A14-BF09-344150448E78/nurie.app/nurie Expected in: /usr/lib/libSystem.B.dylib

dyld: Symbol not found: ___sincos_stret Referenced from: /var/mobile/Applications/49869F6C-A31E-4A14-BF09-344150448E78/nurie.app/nurie Expected in: /usr/lib/libSystem.B.dylib

I've seen some post on the internet about this kind of error but none of them fix my issue. I'm using the last Xcode version (5.0.2).

Could you please tell me how can I fix this issue?

I really thank you for your help

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-11-19 05:02:23 -0500

Hello, I had the same issue, the only way I found to solve it is by rebuilding the framework using the build_framework.py script and adding the minimum target to iOS 6.0 as explained here : http://stackoverflow.com/a/19698826

I think this is an issue with the last Xcode version (5.0.2) because even prebuilt openCV 2.4.6 that was working with Xcode 5.0 and ios6 now leads to the same error.

Hope all goes well !

edit flag offensive delete link more

Comments

Thank you for your answer.

as my target deployment is set to 5.1, is it OK to set minimum target to iOS6.0? I mean, minimum target to iOS6.0 concern the Base SDK or the deployment target?

I've tried to download the openCV2.4.6.1 for linux and mac, edit the python file for ios but when launching the python command I get an error saying that an error occured due to unexpected indentation (I've copy/paste the 2 lines from your url).

Furthermore I guess also an error when trying to compile the original file (sh: cake: command not found).

I launched the python file from the platform/ios folder.

Could you please tell me what I did wrong?

nakano gravatar imagenakano ( 2013-11-20 01:37:58 -0500 )edit

Question Tools

Stats

Asked: 2013-11-13 01:14:05 -0500

Seen: 881 times

Last updated: Nov 19 '13