Ask Your Question
0

Didn't find class "android.view.JavaCameraView" on path: DexPathList[[zip file "==/base.apk"],nativeLibraryDirectories=[==/lib/arm64, ==/base.apk!/lib/arm64-v8a, /system/lib64]]

asked 2020-11-22 20:03:37 -0500

Hello , please help me with the following error. I am doing a sample project using Open Source Computer Vision Library for Android. I imported module OpenCV-3.0.0-android-sdk-1 and created jniLibs folder and added all arm64-v8a,armeabi, armeabi-v7a, mips,mips64,x86,x86_64 from OpenCV-android-sdk\sdk\native\libs folder. Even then I am getting following exception while running the app Didn't find class "android.view.JavaCameraView" on path: DexPathList[[zip file "/data/app/com.app.cvapp-Ef9wN-CbMvciMrDFxxfw_g==/base.apk"],nativeLibraryDirectories=[/data/app/com.app.cvapp-Ef9wN-CbMvciMrDFxxfw_g==/lib/arm64, /data/app/com.app.cvapp-Ef9wN-CbMvciMrDFxxfw_g==/base.apk!/lib/arm64-v8a, /system/lib64]]

edit retag flag offensive close merge delete

Comments

sturkmen gravatar imagesturkmen ( 2020-11-23 00:07:34 -0500 )edit

Hello, Thanks for your reply.I am getting the following error.

Could not determine the dependencies of task ':app:compileDebugJavaWithJavac'.

Could not resolve all task dependencies for configuration ':app:debugCompileClasspath'. Could not resolve project :opencv. Required by: project :app No matching configuration of project :opencv was found. The consumer was configured to find an API of a component, as well as attribute 'com.android.build.api.attributes.BuildTypeAttr' with value 'debug', attribute 'org.jetbrains.kotlin.platform.type' with value 'androidJvm' but: - None of the consumable configurations have attributes.

sunitha premjee gravatar imagesunitha premjee ( 2020-11-27 01:17:16 -0500 )edit

all steps are well explained. be sure you applied all the steps. especially use OpenCV 4.5

sturkmen gravatar imagesturkmen ( 2020-11-27 01:49:31 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2020-11-28 21:26:35 -0500

Yes It worked.Thanks .

I am a Windows user...So gradle.properties entry for linking sdk should have been like this...

opencvsdk=C\:\Users\Example\Downloads\OpenCV-android-sdk

I left it just like in template which is meant for Mac users opencvsdk=/Users/Example/Downloads/OpenCV-android-sdk

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2020-11-22 20:03:37 -0500

Seen: 176 times

Last updated: Nov 22 '20