Ask Your Question
2

OpenCV 3.0.0-dev "Core_globbing" failure

asked 2013-10-30 13:09:19 -0500

JBeale gravatar image

updated 2013-10-31 02:58:51 -0500

berak gravatar image

I compiled opencv 3.0.0-dev from github.com/Itseez/opencv/archive/master.zip on my Raspberry Pi model A (ARMv6, 256M RAM). It took approximately 10 hours. Running bin/opencv_test_core I see many results report "OK" but there is a failure with "Core_globbing". What does this mean?

[----------] 1 test from Core_globbing
[ RUN      ] Core_globbing.accuracy
/mnt/USB1/opencv-master/modules/core/test/test_io.cpp:501: Failure
Expected: (lenas.size()) > (pngLenas.size()), actual: 0 vs 0
[  FAILED  ] Core_globbing.accuracy (11 ms)
[----------] 1 test from Core_globbing (17 ms total)
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
4

answered 2013-11-20 09:49:17 -0500

Chanaka gravatar image

Hi,

I think you have just built your OpenCV Sources and tried to test the compilation by running "./opencv_test_core" in e.g:- "opencv-2.4.7/build/bin" folder.

this testcase fails because there is no input images, therefore take any .jpg and .png pictures and rename these 2 pictures as lena.jpg and lena.png and copy them into "opencv-2.4.7/build/bin" folder and run again..., you will pass this case.

Thanks.

edit flag offensive delete link more

Comments

Thanks that worked for me

theSundayProgrammer gravatar imagetheSundayProgrammer ( 2015-10-17 01:01:35 -0500 )edit

And you can do this copying those provided images from:

samples/java/clojure/simple-sample/resources/images/lena.png and

samples/data/lena.jpg
sergiomcfly gravatar imagesergiomcfly ( 2015-11-26 20:15:30 -0500 )edit
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-10-30 13:09:19 -0500

Seen: 2,999 times

Last updated: Nov 20 '13