Ask Your Question
2

Do you guys have problem using opencv with osx Mavericks?

asked 2013-10-27 15:13:04 -0500

EricYuan gravatar image

Errors appeared since I update my osx to Mavericks (xcode 5.0.1 with new command line tools installed), so I tried to re-install my opencv, and I can hardly install it.

I don't know why and do anyone have same problem?

Thanks

edit retag flag offensive close merge delete

Comments

I can't get it to install at all. I'm using brew, and I tried every version 2.4.3 up to 2.4.6.1 - they all fail in the build process somewhere. I tried to download the source of 2.4.5 and manually build that using make, but that failed too. Like you, I'm using Mavericks + Xcode 5.0.1.

Did you figure it out?

chrism2671 gravatar imagechrism2671 ( 2013-10-29 07:03:20 -0500 )edit
chrism2671 gravatar imagechrism2671 ( 2013-10-29 07:14:33 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2013-10-27 16:05:49 -0500

Ilya Lavrenov gravatar image

I also had the problems with compiling OpenCV, but Xcode updating solved my problem. Could you provide more detailed description?

edit flag offensive delete link more
0

answered 2013-10-28 17:44:18 -0500

updated 2013-10-28 17:44:53 -0500

Hi i have Maverick and i Had a problem to install opencv. You have to install command line tools for Maverick and than you can use homebrew or macports to install. But i got another problem, that didnt appear with Lion. Here it is:

Undefined symbols for architecture x86_64: "cv::imread(std::string const&, int)", referenced from: _main in main.o "cv::imwrite(std::string const&, cv::_InputArray const&, std::vector<int, std::allocator<int=""> > const&)", referenced from I link all necessery .dylib files and set header serach files, architecture, and so on. But still got this problem.

Thank you for all your advices.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-10-27 15:13:04 -0500

Seen: 989 times

Last updated: Oct 28 '13