Ask Your Question
0

Get an error when trying to install openCV. I don't understand the fix.

asked 2020-05-20 19:12:41 -0500

Teejay gravatar image

I am trying to install openCV using the instructions here.

https://medium.com/@sourabhjigjinni/i...

I get the error .... "error: long: No such file or directory".

I can see the solution here.

https://answers.opencv.org/question/2...

I can see some words. They don't mean a thing to me can someone explain what I should do?

General comment. I don't understand why installing OpenCV should be see so difficult. Last time I tried I had difficulty and could only install a version a couple of generations back. Consequently I have been putting off this installation for as long as possible, but it is just as difficult again. I am pretty OK at image processing, you can look at my GitHub account and verify this https://github.com/TJCoding, but I am kind of concerned that I am putting up code on GitHub which other image processing engineers don't benefit from because they too have difficulty installing OpenCV.

edit retag flag offensive close merge delete

Comments

os ? opencv version ? compiler ? (problem seems to be bad support for mingw compiler on win)

did the answer quoted above solve it ?

berak gravatar imageberak ( 2020-05-21 01:14:46 -0500 )edit

As I stated I am following the procedure described here to implement the latest version of openCV. https://medium.com/@sourabhjigjinni/i...

That means I am using the latest version of Windows 10, the latest version of OpenCV (4.3.0), the latest version of cmake (cmake-13.17.2-win64-x64.msi which I am running from cmake-gui.exe), the latest version of tdm64-gcc (9.2.0) and the latest version of CodeBlocks (20.03).

Did the answer quoted above solve it?

No .... because as I explained the answer doesn’t mean anything to me so I can’t try to implement it.

Teejay gravatar imageTeejay ( 2020-05-21 06:14:22 -0500 )edit

Exceeded word count so 2nd comment... ...

It said “try to: cmake -DOPENCV_ENABLE_ALLOCATOR_STATS=OFF but I now believe that this should read try to: cmake-OPENCV_ENABLE_ALLOCATOR_STATS=OFF

I don’t know what “try to: cmake -OPENCV_ENABLE_ALLOCATOR_STATS=OFF”means

I have tried running Command Prompt from the directory that contains CMake.exe and when I type in the above, I get the error that the directory does not contain CMakeLists.txt. Given that there are now at least 100 instances of CMakeLists.txt on my computer across many directories, I do not know what to do next.

Teejay gravatar imageTeejay ( 2020-05-21 06:16:18 -0500 )edit

1 answer

Sort by » oldest newest most voted
-1

answered 2020-05-22 19:20:34 -0500

Teejay gravatar image

I have now gone for a workaround as described below.

Seemingly no one can explain what “try to: cmake –OPENCV_ENABLE_ALLOCATOR_STATS=OFF” means even though it is the apparent solution to my issue. I have spent 2 days trying to work it out for myself but with no luck.

I was trying to follow the implementation here. https://medium.com/@sourabhjigjinni/i..., so my workaround is to follow the excellent guide there but to use the versions of software as given there. (Open CV 4.1.0, cmake 3.13.0, tdm-gcc 5.1.0 and CodeBlocks 20.03). With these versions I no longer get the error “error long no such directory”.

I am left with a dilemma. I recently identified a fault with a longstanding image processing method and I provided a solution in Matlab (Ruggedised Xiao Method https://github.com/hangong/Xiao06_col.... ) It was my intention to provide a version of this in openCV but given my experiences here I am having second thoughts.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-05-20 19:12:41 -0500

Seen: 76 times

Last updated: 2 days ago