Ask Your Question
0

.hpp files include wrong directories

asked 2020-05-11 14:47:56 -0500

Tim... gravatar image

updated 2020-05-12 06:11:17 -0500

Hello there, I recently installed Opencv on my machine running ubuntu. Everything installed without problems using :
sudo cmake -D CMAKE_BUILD_TYPE=Release -D CMAKE_INSTALL_PREFIX=/usr/local .. sudo make sudo make install Now I created a new project with QT, included "opencv4/opencv2/calib3d.hpp" , and now inside that file it says that it cant find another include "opencv2/core.hpp" . I looked inside those directories and it is like it added "opencv2/" in fron of al directories. Of corse the directory opencv2 in all those cases doesnt exist. This is just one example, but it happens with many of the files.

main.cpp:

#include "widget.h" 
#include "opencv4/opencv2/calib3d.hpp"      //includes without any problem
#include  QApplication> // as a normal include

int main(int argc, char *argv[])
{
    QApplication a(argc, argv);
    Widget w;
    w.show();
    return a.exec();
}

Error message:

/usr/local/include/opencv4/opencv2/calib3d.hpp:47: Fehler: opencv2/core.hpp: No such file or directory
 #include "opencv2/core.hpp"
          ^~~~~~~~~~~~~~~~~~

opencv4/opencv2/calib3d.hpp:

/*M///////////////////////////////////////////////////////////////////////////////////////
//
//  IMPORTANT: READ BEFORE DOWNLOADING, COPYING, INSTALLING OR USING.
//
//  By downloading, copying, installing or using the software you agree to this license.
//  If you do not agree to this license, do not download, install,
//  copy or use the software.
//
//
//                          License Agreement
//                For Open Source Computer Vision Library
//
// Copyright (C) 2000-2008, Intel Corporation, all rights reserved.
// Copyright (C) 2009, Willow Garage Inc., all rights reserved.
// Copyright (C) 2013, OpenCV Foundation, all rights reserved.
// Third party copyrights are property of their respective owners.
//
// Redistribution and use in source and binary forms, with or without modification,
// are permitted provided that the following conditions are met:
//
//   * Redistribution's of source code must retain the above copyright notice,
//     this list of conditions and the following disclaimer.
//
//   * Redistribution's in binary form must reproduce the above copyright notice,
//     this list of conditions and the following disclaimer in the documentation
//     and/or other materials provided with the distribution.
//
//   * The name of the copyright holders may not be used to endorse or promote products
//     derived from this software without specific prior written permission.
//
// This software is provided by the copyright holders and contributors "as is" and
// any express or implied warranties, including, but not limited to, the implied
// warranties of merchantability and fitness for a particular purpose are disclaimed.
// In no event shall the Intel Corporation or contributors be liable for any direct,
// indirect, incidental, special, exemplary, or consequential damages
// (including, but not limited to, procurement of substitute goods or services;
// loss of use, data, or profits; or business interruption) however caused
// and on any theory of liability, whether in contract, strict liability,
// or tort (including negligence or otherwise) arising in any way out of
// the use of this software, even if advised of the possibility of such damage.
//
//M*/

#ifndef OPENCV_CALIB3D_HPP
#define OPENCV_CALIB3D_HPP

#include "opencv2/core.hpp"                        //Here are the problems !!!!
#include "opencv2/features2d.hpp"
#include "opencv2/core/affine.hpp"

/**
  @defgroup calib3d Camera Calibration and 3D Reconstruction

                                      //File continues ...

I installed opencv in another directory called /home/tim/OPCV . Inside the include/opencv4 ... (more)

edit retag flag offensive close merge delete

Comments

please remove the screenshots, and add resp. information AS TEXT, thank you !

berak gravatar imageberak ( 2020-05-12 04:18:15 -0500 )edit

and again, this is wrong:

#include "opencv4/opencv2/calib3d.hpp"

it MUST be:

#include "opencv2/calib3d.hpp"
berak gravatar imageberak ( 2020-05-12 06:18:25 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2020-05-12 01:40:21 -0500

berak gravatar image

for opencv4 your include path should be:

-I/usr/local/include/opencv4

and you should include opencv headers like:

#include "opencv2/calib3d.hpp"
edit flag offensive delete link more

Comments

I looks like thats not the problem. I installed opencv again in another place in my home directory, just so I can analyse the problem better. When Im inside the /home/tim/inlcude/opencv4/opencv2 directory, amongst other files there is one called core.hpp . That file (just as an example), is trying to include other files under the directory opencv2/<name of the other file> , but that directorie doesnt exist. In the case of core.hpp it is trying to include 9 files under a directory called opencv2/core/... , but those files are located under the directory core/... . I will add some pictures so yo can understand what I mean.

Tim... gravatar imageTim... ( 2020-05-12 04:07:25 -0500 )edit

I installed opencv again in another place in my home directory,

bad idea, you have to run ldconfig on the bin folder, else it won't find so's at runtime later

please, NO screenshots of code / IDE / errrors here. (use TEXT)

berak gravatar imageberak ( 2020-05-12 04:13:09 -0500 )edit

How do I run Idconfig on the bin folder, and what does it do ?

Tim... gravatar imageTim... ( 2020-05-12 06:13:54 -0500 )edit
1

How do I run Idconfig

please RTFM

berak gravatar imageberak ( 2020-05-12 06:17:11 -0500 )edit

Okay, I got it working. I did include the path the wrong way, sorry for the unnecessary interference. I used INCLUDEPATH+= "/usr/local/include/opencv4"

Tim... gravatar imageTim... ( 2020-05-12 11:46:33 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2020-05-11 14:47:56 -0500

Seen: 254 times

Last updated: May 12 '20