Ask Your Question
0

opencv_videoio_gstreamer420_64.dll load failed +WINRT error

asked 2020-03-06 06:29:58 -0500

Crypto gravatar image

i'm trying to make a simpl-ish image recognition and processing code in openCV 4.20 and c++ in VS19. PRoblem is: it worked fine to an undefined moment, and then suddenly i stopped seeing any image output at all in windows that openCV creates. It should cap image from the webcam and do all the processing stuff, but all it shows now is a blank window, as if there is no image at all. However it passes error checking and all processing, and frame logging outputs all passes as successful (e.g. image captured, processing done, etc). Thing is, the camera capture is definitely running, as i can see the FPS changes in frequency of logs output with the change of camera fps (when i put the camera to a lightsource the fps rises and therefore "frame captured" message is written more frequently.). When i check the init output in console, i see the following messages: [ INFO:0] global C:\build\master_winpack-build-win64-vc15\opencv\modules\videoio\src\videoio_registry.cpp (187) cv::`anonymous-namespace'::VideoBackendRegistry::VideoBackendRegistry VIDEOIO: Enabled backends(7, sorted by priority): FFMPEG(1000); GSTREAMER(990); INTEL_MFX(980); MSMF(970); DSHOW(960); CV_IMAGES(950); CV_MJPEG(940) [ INFO:0] global C:\build\master_winpack-build-win64-vc15\opencv\modules\videoio\src\backend_plugin.cpp (353) cv::impl::getPluginCandidates Found 2 plugin(s) for GSTREAMER [ INFO:0] global C:\build\master_winpack-build-win64-vc15\opencv\modules\videoio\src\backend_plugin.cpp (172) cv::impl::DynamicLib::libraryLoad load C:\opencv\build\x64\vc15\bin\opencv_videoio_gstreamer420_64.dll => FAILED [ INFO:0] global C:\build\master_winpack-build-win64-vc15\opencv\modules\videoio\src\backend_plugin.cpp (172) cv::impl::DynamicLib::libraryLoad load opencv_videoio_gstreamer420_64.dll => FAILED

in visual studio debug console, there is also one error line among module load lines: Exception thrown at 0x00007FFD4F37A839 (KernelBase.dll) in oCVCookies.exe: WinRT originate error - 0xC00D36B3 : 'The stream number provided was invalid.'. from what i can tell, it tries to use VIDEOIO_GSTREAMER420_64.dll but there is no such library in the oCV folder. But somehow it worked before. And it's not related to the code itself either, as when i create a dummy code that ONLY opens the capture, captures a frame and shows it, i encounter the same problem. Again, it worked before a certain moment , but it just stopped working after an unknown event. OpenCV reinstall did not help with the problem. The dummy code i used was something like following:

Mat camframe; 
VideoCapture cap;
cap.open (CAP_ANY, 0);
while (;;)
{
cap.read(camframe);
imshow("feed", camframe);
}
edit retag flag offensive close merge delete

Comments

  • it should be : cap.open(camID, backendID); (wrong order)
  • add a if (waitKey(5) > 0) break;line after the imshow(), else it won't draw anything
  • also try CAP_DSHOW and CAP_MSMF backends
berak gravatar imageberak ( 2020-03-06 06:39:44 -0500 )edit

我也遇到同样的问题,不能解决

chenjia gravatar imagechenjia ( 2020-07-22 02:24:30 -0500 )edit

@chenjia please use only english in this forum

sturkmen gravatar imagesturkmen ( 2020-07-22 05:26:14 -0500 )edit

How did you manage the solve this issue?

Alex Liu gravatar imageAlex Liu ( 2020-07-31 18:59:12 -0500 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2020-07-22 21:17:07 -0500

我的问题解决了,请检查文件的打开路径。 我由于自己的粗心把路径写错了导致这样的报错。请仔细检查打开的文件名和路径是否正确!

edit flag offensive delete link more

Comments

please post in english, not in chinese here, thank you.

berak gravatar imageberak ( 2020-07-23 00:59:57 -0500 )edit

How did you solve this error?

Alex Liu gravatar imageAlex Liu ( 2020-07-31 18:58:23 -0500 )edit

你是如何解决问题的?

Alex Liu gravatar imageAlex Liu ( 2020-07-31 18:59:00 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-03-06 06:29:58 -0500

Seen: 849 times

Last updated: Jul 22