Not able to install opencv on raspberry pi 3 b+. How do I resolve it?[SOLVED] [closed]

asked 2020-02-11 06:16:29 -0500

success gravatar image

updated 2020-02-13 03:52:03 -0500

supra56 gravatar image

Hello,

I am trying to install the opencv on raspberry pi 3 b+. I am not getting any error but the process is not completed. When I am running the "make -j4" command the process continues till 100% and stops. No error, nothing. When I interrupt it then it says interruption error. I am following this https://circuitdigest.com/microcontro....

image description

Please help me out with this. I have tried it for two time. Facing same issues.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by supra56
close date 2020-02-13 03:53:04.500276

Comments

please, no screenshots of code / errors here. edit, and replace with a TEXT version, so we can quote you, it can be indexed, etc, thank you.

berak gravatar imageberak ( 2020-02-11 07:11:26 -0500 )edit

the process continues till 100% and stops. No error, nothing. You supposed to wait at least 1 hrs. Do not interrupt your pi. In build's folder, delete it and do cmake again

supra56 gravatar imagesupra56 ( 2020-02-11 09:04:34 -0500 )edit

At[100%], it will do something to write. But be patient wait at least 1 hrs. You will see done or pi@raspberry $.

supra56 gravatar imagesupra56 ( 2020-02-11 09:18:37 -0500 )edit

Thank you for the response. It's been more than an hour I have kept it for installation. But still no updates.

success gravatar imagesuccess ( 2020-02-11 23:45:00 -0500 )edit

Didn't you get more than 100%? You should wait an extra hr at least up to 4 hrs. Try this link install opencv 4 for rpi 3B+

supra56 gravatar imagesupra56 ( 2020-02-12 03:21:38 -0500 )edit

No, it didn't cross 100%. Around 10:30 in morning the status was 100%. Still it is the same. No change. I am trying to install opencv-4.0.0 and python 2.7.16 on Raspberry pi 3 b+ model. Does the version affects the installation process?

success gravatar imagesuccess ( 2020-02-12 03:40:40 -0500 )edit

No! You don't do that older version. If not make -j4 then try make -j1. The older version contained a lot of bugs.

supra56 gravatar imagesupra56 ( 2020-02-12 03:48:30 -0500 )edit

okay. I will try it out

success gravatar imagesuccess ( 2020-02-12 03:57:21 -0500 )edit

Are you using Buster v10?

supra56 gravatar imagesupra56 ( 2020-02-12 04:02:07 -0500 )edit

No. I'm not using Buster v10

success gravatar imagesuccess ( 2020-02-12 04:14:27 -0500 )edit