Ask Your Question
1

error when running warpPolar

asked 2020-01-07 21:01:13 -0500

Eyal321 gravatar image

When I run the warpPolar I get the result I was expecting. But when I run it on a larger image dftcv_shft.shape, I get (19222, 19418, 2). When trying to run warpPolar on that image Iget the following error:

error: OpenCV(4.2.0) D:\Build\OpenCV\opencv-4.2.0\modules\imgproc\src\imgwarp.cpp:1724: error: (-215:Assertion failed) dst.cols < SHRT_MAX && dst.rows < SHRT_MAX && src.cols < SHRT_MAX && src.rows < SHRT_MAX in function 'cv::remap'

According to warpPolar documentation the array needs be smaller than 32767x32767, which it is but seems to me the error is linked to the size of the array. But it seems the error is from remap!?

Any help would be appreciated.

link to warpPolar

link to remap

edit retag flag offensive close merge delete

Comments

Well, looking at the source code, warpPolar calls remap

mvuori gravatar imagemvuori ( 2020-01-08 03:51:54 -0500 )edit

Right, and remap should be good for arrays smaller than 32767X32767, so what is the problem?

Eyal321 gravatar imageEyal321 ( 2020-01-08 14:36:56 -0500 )edit

I am not good in english but I think doc is wrong. It should be :Due to current implementation limitations row and column size of an input and output images should be less than 32767.

May be you can post an issue

LBerger gravatar imageLBerger ( 2020-01-08 14:41:59 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2020-03-03 14:37:35 -0500

Eyal321 gravatar image

The problem was that the output array was larger than 32767X32767

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2020-01-07 21:01:13 -0500

Seen: 142 times

Last updated: Mar 03 '20