CUDA BLAS library - libcublas

asked 2019-12-02 04:10:30 -0500

Martian gravatar image

After numerous attempts to build OpenCV 4.1.2 with WITH_CUBLAS enabled, I'm ready to give up.

The latest CUDA versions changed the location of the library (to /usr/lib//usr/lib/x86_64-linux-gnu/usr/lib/x86_64-linux-gnu/libcublas.so.10.2.1.243). Now, even the latest CMake-gui doesn't correctly detect it. Nor does CMake accept a hand-entered location. It keeps reverting to CUDA_cublas_LIBRARY-NOTFOUND.

It's hard to tell what CMake-gui and OpenCV are looking for. The "Configure" button generates a long list of related errors:

CMake Error: The following variables are used in this project, but they are set to NOTFOUND. CUDA_cublas_LIBRARY (ADVANCED) linked by target "opencv_cudev" in directory /DM_Util/_INSTALL_LINUX/OpenCV_4/OpenCV_4.1.2_2019nov20/opencv_contrib/modules/cudev linked by target "opencv_test_cudev" in directory ... etc.

Q: What is the downside to just disabling the WITH_CUBLAS option? Is there likely to be a considerable performance hit (wild guesses welcome)? It looks like libatlas.so links with no problems, but it would be nice to be assured of hardware acceleration via CUDA....if it's even used by OpenCV.

Again, I'm open to wild speculation at this point. I haven't found any leads on NVidia or CMake forums.

edit retag flag offensive close merge delete

Comments

1

You need to install tensflow to get it working.

supra56 gravatar imagesupra56 ( 2019-12-02 04:50:31 -0500 )edit

Thanks for getting back, Supra.

Tensorflow 2.0 GPU version was already installed (via Anaconda). That doesn't seem to affect anything, at least in the build process.

In case that wasn't clear: The problem is in building OpenCV. Is that what you were referring to? (It sounded like maybe you meant running application code...?)

Martian gravatar imageMartian ( 2019-12-03 04:51:43 -0500 )edit