Ask Your Question
0

Using XCode - missing required architecture x86_64 in file opencv

asked 2013-10-08 17:20:40 -0500

opencvlucy gravatar image

After trying many suggestions, I commented out all calls to OpenCV and tried to build my project. This is the error I am now getting. Can someone please tell me what this means?

Ld /Users/pdl/Library/Developer/Xcode/DerivedData/pdl-gcadehxhpanobrgyqerfrgygapyp/Build/Products/Debug/pdl.framework/Versions/A/pdl normal x86_64 cd /Users/pdl/Development/pdl/pdl setenv MACOSX_DEPLOYMENT_TARGET 10.8 /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang++ -arch x86_64 -dynamiclib -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.8.sdk -L/Users/pdl/Library/Developer/Xcode/DerivedData/pdl-gcadehxhpanobrgyqerfrgygapyp/Build/Products/Debug -F/Users/pdl/Library/Developer/Xcode/DerivedData/pdl-gcadehxhpanobrgyqerfrgygapyp/Build/Products/Debug -F/Users/pdl/Development/pdl/pdl -filelist /Users/pdl/Library/Developer/Xcode/DerivedData/pdl-gcadehxhpanobrgyqerfrgygapyp/Build/Intermediates/pdl.build/Debug/pdl.build/Objects-normal/x86_64/pdl.LinkFileList -install_name @executable_path/../Frameworks/pdl.framework/Versions/A/pdl -mmacosx-version-min=10.8 -stdlib=libc++ -framework opencv2 -framework Cocoa -single_module -compatibility_version 1 -current_version 1 -Xlinker -dependency_info -Xlinker /Users/pdl/Library/Developer/Xcode/DerivedData/pdl-gcadehxhpanobrgyqerfrgygapyp/Build/Intermediates/pdl.build/Debug/pdl.build/Objects-normal/x86_64/pdl_dependency_info.dat -o /Users/pdl/Library/Developer/Xcode/DerivedData/pdl-gcadehxhpanobrgyqerfrgygapyp/Build/Products/Debug/pdl.framework/Versions/A/pdl

ld: warning: ignoring file /Users/pdl/Development/pdl/pdl/opencv2.framework/opencv2, missing required architecture x86_64 in file /Users/pdl/Development/pdl/pdl/opencv2.framework/opencv2 (3 slices)

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-10-11 00:05:42 -0500

opencvlucy gravatar image

I was compiling to 64-bit and OpenCV does not support that. Maybe because of cross architecture support. We changed to Universal (32/64-bit) and that seemed to make it work. There were a few more Xcode configurations that needed to be tweaked but that was the reason for the error.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-10-08 17:20:40 -0500

Seen: 3,255 times

Last updated: Oct 11 '13