Jetson TX2, Parrot Olympe, and OpenCV

asked 2019-10-29 14:04:06 -0500

Running into a wall here and been looking for a solution:

Recently been trying to install Parrot Olympe onto a Jetson TX2, and when I try to install olympe-linux dependencies, it throws back an error that:

ERROR: Could not find a version that satisfies the requirement python-opencv (from -r /home/aware/code/parrot-groundsdk/packages/olympe/requirements.txt (line 10)) (from versions: none) ERROR: No matching distribution found for python-opencv (from -r /home/aware/code/parrot-groundsdk/packages/olympe/requirements.txt (line 10))

I have gone through the steps to manually build OpenCV, from https://docs.opencv.org/master/d2/de6/tutorial_py_setup_in_ubuntu.html, which seems to successfully build, or at the very least, allows me to verify that the installed version is 4.1.2-dev.

import cv2 as cv
print(cv.__version__)
4.1.2-dev

I imagine there's a simple step that I'm missing, I'm just not sure what it is.

edit retag flag offensive close merge delete