Ask Your Question
0

OpenCV failure while executing stitching in GPU

asked 2019-09-10 06:13:57 -0500

Harsh1307 gravatar image

updated 2019-09-16 03:22:27 -0500

LBerger gravatar image

Hi Team,

I am trying to execute image stitching in cuda device but continuously getting "core dump" error.

Please give your inputs to resolve an issue.

Related Information:

Board: Jetson Tx2 and Jetson nano Cuda version: 10.0 OpenCv version: 3.4.0 [cuda support is enabled while installing openCV]

*Error:* [ INFO:0] Initialize OpenCL runtime... OpenCV Error: The function/feature is not implemented (The called functionality is disabled for current build or platform) in throw_no_cuda, file /home/einfochips/opencv-3.4.0/modules/core/include/opencv2/core/private.cuda.hpp, line 111 terminate called after throwing an instance of 'cv::Exception' what(): /home/einfochips/opencv-3.4.0/modules/core/include/opencv2/core/private.cuda.hpp:111: error: (-213) The called functionality is disabled for current build or platform in function throw_no_cuda Aborted (core dumped)

pseudo code:

  1. Read 2 Images one by one using Imread
  2. Uploaded on GPU using cuda::matrix.upload
  3. copy images in the Vector SRC
  4. Enabled stitcher using try_gpu= true to execute in cuda device
  5. Download stitched image to cv::Matrix
  6. Write image in result.jpg

Please let me know if any further information is required.

Thanks and regards, Harsh

Build Information:
===================

Python 3.6.8 (default, Aug 20 2019, 17:12:48)
[GCC 8.3.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
import cv2
>> print(cv2.getBuildInformation())
General configuration for OpenCV 3.4.2 =====================================
 Version control:               3.4.2
 Extra modules:
   Location (extra):            /io/opencv_contrib/modules
   Version control (extra):     3.4.2
 Platform:
   Timestamp:                   2018-07-21T19:43:53Z
   Host:                        Linux 4.4.0-101-generic x86_64
   CMake:                       3.9.0
   CMake generator:             Unix Makefiles
   CMake build tool:            /usr/bin/gmake
   Configuration:               Release
 CPU/HW features:
   Baseline:                    SSE SSE2 SSE3
     requested:                 SSE3
   Dispatched code generation:  SSE4_1 SSE4_2 FP16 AVX AVX2
     requested:                 SSE4_1 SSE4_2 AVX FP16 AVX2 AVX512_SKX
     SSE4_1 (3 files):          + SSSE3 SSE4_1
     SSE4_2 (1 files):          + SSSE3 SSE4_1 POPCNT SSE4_2
     FP16 (1 files):            + SSSE3 SSE4_1 POPCNT SSE4_2 FP16 AVX
     AVX (5 files):             + SSSE3 SSE4_1 POPCNT SSE4_2 AVX
     AVX2 (9 files):            + SSSE3 SSE4_1 POPCNT SSE4_2 FP16 FMA3 AVX AVX2"

C/C++:
   Built as dynamic libs?:      NO
   C++ Compiler:                /opt/rh/devtoolset-2/root/usr/bin/c++  (ver 4.8.2)
   C++ flags (Release):         -Wl,-strip-all   -fsigned-char -W -Wall -Werror=return-type -Werror=non-virtual-dtor -Werror=address -Werror=sequence-point -Wformat -Werror=format-security -Wmissing-declarations -Wundef -Winit-self -Wpointer-arith -Wshadow -Wsign-promo -Wuninitialized -Winit-self -Wno-narrowing -Wno-delete-non-virtual-dtor -Wno-comment -fdiagnostics-show-option -Wno-long-long -pthread -fomit-frame-pointer -ffunction-sections -fdata-sections  -msse -msse2 -msse3 -fvisibility=hidden -fvisibility-inlines-hidden -O3 -DNDEBUG  -DNDEBUG
   C++ flags (Debug):           -Wl,-strip-all   -fsigned-char -W -Wall -Werror=return-type -Werror=non-virtual-dtor -Werror=address -Werror=sequence-point -Wformat -Werror=format-security -Wmissing-declarations -Wundef -Winit-self -Wpointer-arith -Wshadow -Wsign-promo -Wuninitialized -Winit-self -Wno-narrowing -Wno-delete-non-virtual-dtor -Wno-comment -fdiagnostics-show-option -Wno-long-long -pthread -fomit-frame-pointer -ffunction-sections -fdata-sections  -msse -msse2 -msse3 -fvisibility=hidden -fvisibility-inlines-hidden -g  -O0 -DDEBUG -D_DEBUG
   C Compiler:                  /opt/rh/devtoolset-2/root/usr/bin/cc
   C flags (Release):           -Wl,-strip-all   -fsigned-char -W -Wall -Werror=return-type -Werror=non-virtual-dtor -Werror=address -Werror=sequence-point -Wformat -Werror=format-security -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wundef -Winit-self -Wpointer-arith -Wshadow -Wuninitialized -Winit-self -Wno-narrowing -Wno-comment -fdiagnostics-show-option -Wno-long-long -pthread -fomit-frame-pointer -ffunction-sections -fdata-sections  -msse -msse2 ...
(more)
edit retag flag offensive close merge delete

Comments

Can you try using this source code?

LBerger gravatar imageLBerger ( 2019-09-10 06:42:33 -0500 )edit

Hi

Thank you for your Input...

I have tried suggested example but getting same issue while using "--try_cuda yes":

[371.5999523834391, 0, 128;
 0, 371.5999523834391, 128;
 0, 0, 1]
R:
[1, -5.4462195e-09, -1.129996e-08;
 6.231061e-09, 1, 1.042721e-09;
 -1.1734755e-09, -4.4025228e-11, 1]
Warping images (auxiliary)... 
Warping images, time: 0.154762 sec
terminate called after throwing an instance of 'cv::Exception'
  what():  OpenCV(3.4.4) /home/einfochips/opencv-3.4.4/modules/core/include/opencv2/core/private.cuda.hpp:113: error: (-213:The function/feature is not implemented) The called functionality is disabled for cur
Harsh1307 gravatar imageHarsh1307 ( 2019-09-11 00:51:45 -0500 )edit

with try_cuda no is it OK?

LBerger gravatar imageLBerger ( 2019-09-11 02:23:17 -0500 )edit

Yes, with try_cuda no, It is working

Harsh1307 gravatar imageHarsh1307 ( 2019-09-11 02:53:50 -0500 )edit

try with --try_cuda yes --seam gc_colorgrad

and after

--try_cuda yes --seam no

LBerger gravatar imageLBerger ( 2019-09-11 03:19:55 -0500 )edit

Hi LBerger,

Thank you for your quick response

I have tried both the option and working as expected only with following arguments: --try_cuda yes --seam no

Appreciated if i get the reason, why its not working with other --seam parameters?

Thanks again Regards, Harsh

Harsh1307 gravatar imageHarsh1307 ( 2019-09-11 07:12:26 -0500 )edit
1

cuda is used only with option gc_colorgrad and gc_color(default).

Have you got a stack trace?

Can you post getBuildInformation()?

LBerger gravatar imageLBerger ( 2019-09-11 08:21:52 -0500 )edit

in cmake output :

   Unavailable:                 cnn_3dobj cudaarithm cudabgsegm cudacodec cudafeatures2d cudafilters cudaimgproc cudalegacy cudaobjdetect cudaoptflow cudastereo cudawarping cudev cvv freetype hdf java matlab ovis python2 sfm ts viz
LBerger gravatar imageLBerger ( 2019-09-16 03:56:09 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2019-09-16 06:05:43 -0500

Harsh1307 gravatar image

Hi LBerger,

Will it work if, i add all these flags as "Yes" while building openCV?

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-09-10 06:13:57 -0500

Seen: 46 times

Last updated: Sep 16