Ask Your Question
0

Non-free algorithms stays NO Ubuntu 16.04 opencv-3.4.4

asked 2019-08-09 08:08:42 -0500

GBrouwer gravatar image

updated 2019-08-09 09:13:36 -0500

Hi,

I am on Ubuntu 16.04 (clean install) following this tutorial . Instead of 3.1.0 I tried to install 3.4.6 which did not work, because the Non-free algorithms are not being included. I again tried with version 3.4.4 which again did not work.

The CMAKE command I use:

cmake -D CMAKE_BUILD_TYPE=RELEASE \ 
-D CMAKE_INSTALL_PREFIX=/usr/local \ 
-D INSTALL_PYTHON_EXAMPLES=ON \ 
-D INSTALL_C_EXAMPLES=OFF \ 
-D OPENCV_ENABLE_NONFREE=ON \ 
-D OPENCV_EXTRA_MODULES_PATH=/home/gertjan/opencv_contrib-3.4.4/modules \ 
-D BUILD_EXAMPLES=ON ..

Pastebin containing my cmake output, since formatting in this editor is impossible. Pastebin containing all cmake output which produced an error.

edit retag flag offensive close merge delete

Comments

please remove screen shot ans insert cmake output as text in post

LBerger gravatar imageLBerger ( 2019-08-09 08:57:48 -0500 )edit

line 392 hints, that the xfeatures2d module won't be built. unfortunatly, the reason is not visible from your pastebin.

can you try to clean the build folder completely, and try again with cmake ?

unless you have xfeatures2d in the -- To be built: section, there can't be any SIFT or SURF code, irrespective of the nonfree flag.

berak gravatar imageberak ( 2019-08-09 11:24:35 -0500 )edit

opencv_contrib path is wrong? in my cmakeoutput I have got this:

--
-- General configuration for OpenCV 4.1.1-dev ==================================                                                                                                                             ===
--   Version control:               4.0.1-1271-gf1ea9d86b9
--
--   Extra modules:
--     Location (extra):            G:/Lib/opencv_contrib/modules
--     Version control (extra):     3.4.1-575-g3ad82f9d

How di you install opencv_contrib?

LBerger gravatar imageLBerger ( 2019-08-09 11:58:04 -0500 )edit

I downloaded the zip from github releases and unzipped it. I tried with opencv_contrib-3.4.4 and renamed to opencv_contrib afterwards. Both don't work I am now on Ubuntu 18.04 trying the same thing. Which again does not work, I am now following this tutorial . I am skipping the python virtualenv part since I don't need python

GBrouwer gravatar imageGBrouwer ( 2019-08-09 13:58:25 -0500 )edit

Alright this is f** weird. From the tutorial I linked above I skipped this step partially: Step #3: Configure your Python 3 virtual environment for OpenCV 4 I did install pip as the first step states, but afterwards I immediatly pip3 install numpy. Then I skip the rest, because I don't want to install virtualenv becuase I am not going to work with python. But I figure I try with this step anyway and now the algorithms are included. Can anyone explain why that is?

GBrouwer gravatar imageGBrouwer ( 2019-08-09 14:12:51 -0500 )edit

You can try something like this. I know it's window. but with git bash it's easy to adapt in linux

LBerger gravatar imageLBerger ( 2019-08-09 14:14:36 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-08-09 09:01:27 -0500

LBerger gravatar image

updated 2019-08-09 09:11:58 -0500

remove all spaces between -D OPENCV_...

delete cmakecahe.txt

see readme.md https://github.com/opencv/opencv_contrib

edit flag offensive delete link more

Comments

This has no effect on the output, still the same problem

GBrouwer gravatar imageGBrouwer ( 2019-08-09 09:09:43 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-08-09 08:08:42 -0500

Seen: 30 times

Last updated: Aug 09