Windows 10 building openCV.js

asked 2019-07-26 06:56:52 -0500

kavikode gravatar image

updated 2019-07-26 07:16:16 -0500

supra56 gravatar image

I am having trouble building OpenCV.js on Windowa 10 64 bit. Will you please help me?

For installing Emscripten SDK, I used emsdk-1.35.0-full-64bit.exe, link: https://emscripten.org/docs/getting_s...

I have the following configuration: Python 2.7.14 gcc (MinGW.org GCC-8.2.0-3) 8.2.0 Node 8.10.0 g++ (MinGW.org GCC-8.2.0-3) 8.2.0 git 2.18.0.windows.1 java 1.7.0_45 Java(TM) SE Runtime Environment (build 1.7.0_45-b18) Java HotSpot(TM) 64-Bit Server VM (build 24.45-b08, mixed mode) cmake 3.15.0

After I type "python ./platforms/js/build_js.py build_js --emscripten_dir=~/emsdk/" I get the following error message:

Args: Namespace(build_dir='build_js', build_doc=False,
build_test=False, build_wasm=False, clean_build_dir=False,
config_only=False, disable_wasm=False, emscripten_dir='~/emsdk/',
enable_exception=False, opencv_dir='C:\\Users\\Kavita\\opencv',
skip_config=False)
Check dir C:\Users\Kavita\opencv\build_js (create: True, clean: False)
Check dir C:\Users\Kavita\opencv (create: False, clean: False)
Check dir C:\Users\Kavita\opencv\~\emsdk (create: False, clean: False)

=====

===== Config OpenCV.js build for default targe:

Executing: ['cmake', '-DCMAKE_BUILD_TYPE=Release',
"-DCMAKE_TOOLCHAIN_FILE='C:\\Users\\Kavita\\opencv\\~\\emsdk\\cmake\\Modules\\Platform\\Emscripten.cmake'",
"-DCPU_BASELINE=''", "-DCPU_DISPATCH=''", '-DCV_TRACE=OFF',
'-DBUILD_SHARED_LIBS=OFF', '-DWITH_1394=OFF', '-DWITH_ADE=OFF',
'-DWITH_VTK=OFF', '-DWITH_EIGEN=OFF', '-DWITH_FFMPEG=OFF',
'-DWITH_GSTREAMER=OFF', '-DWITH_GTK=OFF', '-DWITH_GTK_2_X=OFF',
'-DWITH_IPP=OFF', '-DWITH_JASPER=OFF', '-DWITH_JPEG=OFF',
'-DWITH_WEBP=OFF', '-DWITH_OPENEXR=OFF', '-DWITH_OPENGL=OFF',
'-DWITH_OPENVX=OFF', '-DWITH_OPENNI=OFF', '-DWITH_OPENNI2=OFF',
'-DWITH_PNG=OFF', '-DWITH_TBB=OFF', '-DWITH_PTHREADS_PF=OFF',
'-DWITH_TIFF=OFF', '-DWITH_V4L=OFF', '-DWITH_OPENCL=OFF',
'-DWITH_OPENCL_SVM=OFF', '-DWITH_OPENCLAMDFFT=OFF',
'-DWITH_OPENCLAMDBLAS=OFF', '-DWITH_GPHOTO2=OFF', '-DWITH_LAPACK=OFF',
'-DWITH_ITT=OFF', '-DWITH_QUIRC=OFF', '-DBUILD_ZLIB=ON',
'-DBUILD_opencv_apps=OFF', '-DBUILD_opencv_calib3d=ON',
'-DBUILD_opencv_dnn=ON', '-DBUILD_opencv_features2d=ON',
'-DBUILD_opencv_flann=ON', '-DBUILD_opencv_gapi=OFF',
'-DBUILD_opencv_ml=OFF', '-DBUILD_opencv_photo=ON',
'-DBUILD_opencv_imgcodecs=OFF', '-DBUILD_opencv_shape=OFF',
'-DBUILD_opencv_videoio=OFF', '-DBUILD_opencv_videostab=OFF',
'-DBUILD_opencv_highgui=OFF', '-DBUILD_opencv_superres=OFF',
'-DBUILD_opencv_stitching=OFF', '-DBUILD_opencv_java=OFF',
'-DBUILD_opencv_java_bindings_generator=OFF', '-DBUILD_opencv_js=ON',
'-DBUILD_opencv_python2=OFF', '-DBUILD_opencv_python3=OFF',
'-DBUILD_opencv_python_bindings_generator=OFF',
'-DBUILD_EXAMPLES=OFF', '-DBUILD_PACKAGE=OFF', '-DBUILD_TESTS=OFF',
'-DBUILD_PERF_TESTS=OFF', '-DBUILD_DOCS=OFF',

'C:\Users\Kavita\opencv'] Re-run cmake no build system arguments CMake Deprecation Warning at C:/Program Files/CMake/share/cmake-3.15/Modules/CMakeForceCompiler.cmake:75 (message): The CMAKE_FORCE_C_COMPILER macro is deprecated. Instead just set CMAKE_C_COMPILER and allow CMake to identify the compiler. Call Stack (most recent call first): C:/Program Files/Emscripten/emscripten/1.35.0/cmake/Modules/Platform/Emscripten.cmake:98 (CMAKE_FORCE_C_COMPILER) build_js/CMakeFiles/3.15.0/CMakeSystem.cmake:6 (include) CMakeLists.txt:137 (project)

CMake Deprecation Warning at C:/Program Files/CMake/share/cmake-3.15/Modules/CMakeForceCompiler.cmake:89 (message): The CMAKE_FORCE_CXX_COMPILER macro is deprecated. Instead just set CMAKE_CXX_COMPILER and allow CMake to identify the compiler. Call Stack (most recent call first): C:/Program Files/Emscripten/emscripten/1.35.0/cmake/Modules/Platform/Emscripten.cmake:99 (CMAKE_FORCE_CXX_COMPILER) build_js/CMakeFiles/3.15.0/CMakeSystem.cmake:6 (include) CMakeLists.txt:137 (project)

CMake Deprecation Warning at C:/Program Files/CMake/share/cmake-3.15/Modules/CMakeForceCompiler.cmake:75 (message): The CMAKE_FORCE_C_COMPILER macro is deprecated. Instead just set CMAKE_C_COMPILER and allow CMake to identify the compiler. Call Stack (most recent call first): C:/Program Files/Emscripten ... (more)

edit retag flag offensive close merge delete