Ask Your Question
0

Tracking.hpp library not found

asked 2019-07-17 00:58:20 -0500

I am coding on a tracking application for which i have used opencv (version 3.4.1) c++ platform in a linux operating system (ubuntu version 14.04). Firstly, I am trying to run a sample code given in the following page https://docs.opencv.org/3.4.1/d2/d0a/... But i found an error as Tracking.hpp no found, No such file or directory. How could i include that library Please suggest me with an idea.

Thanks and regards!

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-07-17 01:42:54 -0500

berak gravatar image

the tracking module is not part of main opencv, you have to get the opencv_contrib repo (see README there !) and rebuild the opencv libs, cmake && make && make install ..

please make sure, you checkout exactly the same contrib version as your main opencv repo (maybe you even want to update that to a more recent version !)

edit flag offensive delete link more

Comments

Thank you.I have downloaded opencv_contrib-3.4.1 and started rebuilding by adding cmake -D OPENCV_EXTRA_MODULES_PATH=../../opencv_contrib/modules .. This has completed successfully. After that i ran the command make -j5. it started building libraries and at 16% of completion, an error occurred. How could i solve this error. Please have a look at this..

[ 16%] Building CXX object modules/stitching/CMakeFiles/opencv_stitching_pch_dephelp.dir/opencv_stitching_pch_dephelp.cxx.o /home/hemashre/OPENCV/opencv-3.4.1/modules/stitching/include/opencv2/stitching/detail/matchers.hpp:52:42: fatal error: opencv2/xfeatures2d/cuda.hpp: No such file or directory # include "opencv2/xfeatures2d/cuda.hpp" ^ compilation terminated. make[2]: * [modules/stitching/CM

Hemasree gravatar imageHemasree ( 2019-07-17 05:24:44 -0500 )edit

try to:

  • clean the build folder
  • disable precompiled headers (cmake -DENABLE_PRECOMPILED_HEADERS=OFF)
berak gravatar imageberak ( 2019-07-17 08:03:54 -0500 )edit

I started rebuilding the directory again. I got an error after completing 81%. And the error is /home/hemashre/OPENCV/opencv_contrib-3.4.1/modules/xfeatures2d/src/boostdesc.cpp:653:37: fatal error: boostdesc_bgm.i: No such file or directory #include "boostdesc_bgm.i" ^ compilation terminated. make[2]: * [modules/xfeatures2d/CMakeFiles/opencv_xfeatures2d.dir/src/boostdesc.cpp.o] Error 1 make[1]: [modules/xfeatures2d/CMakeFiles/opencv_xfeatures2d.dir/all] Error 2 make: ** [all] Error 2

Hemasree gravatar imageHemasree ( 2019-07-17 08:37:16 -0500 )edit

@berak My main motive is to have tracking module. That was build alraedy but the compilation during make was stop due to fatal error: boostdesc_bgm.i: No such file or directory #include "boostdesc_bgm.i". But this is not my concern. How could i avoid this error and proceed to run the applications of tracking.hpp Please have a look into this

Hemasree gravatar imageHemasree ( 2019-07-18 02:35:56 -0500 )edit

boostdesc_bgm.i

needed for the xfeatures2d module (only.) cmake tried to download some (~12) pretrained descriptor models from the net, but failed (e.g your curl could not talk https)

again, the tracking module does not depend on it (as of now).

either fix cmake/curl, or load the missing files manually, or disable the xfeatures2d module: cmake -DBUILD_opencv_xfeaures2d=OFF

berak gravatar imageberak ( 2019-07-18 02:46:24 -0500 )edit

@berak Thank you. It worked and i could able to compile the tracking codes. A executable file has created. But while executing it. there is an error. ./tracking: error while loading shared libraries: libopencv_tracking.so.3.4: cannot open shared object file: No such file or directory Please look into this issue.

Hemasree gravatar imageHemasree ( 2019-07-18 04:19:47 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-07-17 00:55:14 -0500

Seen: 25 times

Last updated: Jul 17