Install Issue: mkdir: cannot create directory ‘Build’: File exists

asked 2019-07-09 09:32:05 -0500

ikmcdaniel2003 gravatar image

updated 2019-07-10 10:05:07 -0500

Hi, I'm following the guide for installing OpenCV on Windows with get-bash and cmake on windows and I get the error below. Please help. Thanks!

The process I used: 1. First I followed the build instructions for installing opencv on Windows (published by opencv.org) using get-bash and cmake, but with opencv apps "on". 2. After opencv was installed (or after I thought it was installed), I tried to useing the command 'opencv_createsamples' to build a vector file but this threw an error that 'opencv_creatsamples' was not defined. At this point I figured the install did not work. 3. I deleted c/lib (where I installed opencv)and tried to go through the opencv install procedure again 4. The second attempt to install opencv failed, saying "Build: File exists?

mkdir: cannot create directory ‘Build’: File exists

edit retag flag offensive close merge delete

Comments

1
  • get-bash -- what ?

  • I'm following the guide for installing OpenCV -- which ?

can you edit your question, and show us your previous steps, exactly ?

berak gravatar imageberak ( 2019-07-09 10:31:44 -0500 )edit
1

Hi Berak. I added the previous steps I used. Thank you very much for your help!

ikmcdaniel2003 gravatar imageikmcdaniel2003 ( 2019-07-10 10:05:49 -0500 )edit
1
  1. again - where does (what?) say anything about get-bash ? sorry, still entirely unclear, what you did exactly.
  2. -- those tools are no more built in recent opencv (deprecated c-api, sad, but not your fault, and not an error) . also note, that 95% of all attempts to train cascades fail simply, because ppl had the wrong expectation about it, wrong or not enough data. if that was your final goal, maybe ask a seperate, more detailled question about it.
berak gravatar imageberak ( 2019-07-10 15:30:39 -0500 )edit