Ask Your Question
0

Unable to build opencv on the raspberry pi running raspbian

asked 2013-09-22 11:16:00 -0500

Pranav Lal gravatar image

Hi all, I am trying to build opencv version 2.4.6.1 on Raspbian (Linux raspberrypi 3.6.11+ #538 PREEMPT Fri Aug 30 20:42:08 BST 2013 armv6l) running on a raspberry pi B. I am following the instructions at the following link; http://denis.doublebuffer.net/lablog/2012/08/10/setting-everything-up-for-opencv-raspberry-pi/ Make stops around 61%. See the following error dump.

[ 67%] Building CXX object modules/gpu/CMakeFiles/opencv_gpu.dir/src/denoising.cpp.o
[ 67%] Building CXX object modules/gpu/CMakeFiles/opencv_gpu.dir/src/bilateral_filter.cpp. o
Linking CXX shared library ../../lib/libopencv_gpu.so
[ 67%] Built target opencv_gpu
[ 67%] Generating opencv_perf_gpu_pch_dephelp.cxx
[ 68%] Building CXX object modules/gpu/CMakeFiles/opencv_perf_gpu_pch_dephelp.dir/opencv_p erf_gpu_pch_dephelp.cxx.o
Linking CXX static library ../../lib/libopencv_perf_gpu_pch_dephelp.a
[ 68%] Built target opencv_perf_gpu_pch_dephelp
[ 68%] Generating perf_precomp.hpp
[ 68%] Generating perf_precomp.hpp.gch/opencv_perf_gpu_RELEASE.gch
[ 68%] Built target pch_Generate_opencv_perf_gpu
[ 68%] Building CXX object modules/gpu/CMakeFiles/opencv_perf_gpu.dir/perf/perf_precomp.cp p.o
[ 68%] Building CXX object modules/gpu/CMakeFiles/opencv_perf_gpu.dir/perf/perf_video.cpp. o
[ 69%] Building CXX object modules/gpu/CMakeFiles/opencv_perf_gpu.dir/perf/perf_features2d .cpp.o
[ 69%] Building CXX object modules/gpu/CMakeFiles/opencv_perf_gpu.dir/perf/perf_calib3d.cp p.o
[ 69%] Building CXX object modules/gpu/CMakeFiles/opencv_perf_gpu.dir/perf/perf_labeling.c pp.o
[ 69%] Building CXX object modules/gpu/CMakeFiles/opencv_perf_gpu.dir/perf/perf_denoising. cpp.o
[ 69%] Building CXX object modules/gpu/CMakeFiles/opencv_perf_gpu.dir/perf/perf_main.cpp.o [ 69%] Building CXX object modules/gpu/CMakeFiles/opencv_perf_gpu.dir/perf/perf_core.cpp.o c++: internal compiler error: Killed (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <file: usr="" share="" doc="" gcc-4.6="" readme.bugs=""> for instructions.
make[2]: * [modules/gpu/CMakeFiles/opencv_perf_gpu.dir/perf/perf_core.cpp.o] Error 4
make[1]:
[modules/gpu/CMakeFiles/opencv_perf_gpu.dir/all] Error 2
make: *
* [all] Error 2

How do I see what the problem is and correct it?

Pranav

edit retag flag offensive close merge delete

Comments

why there are "...gpu..." in the compiling message when you using "Raspberry Pi"

Have you selected any "BUILD_opencv_gpu", "with CUDA", "with CUFFT", or "with CUBLAS"?

maythe4thbewithu gravatar imagemaythe4thbewithu ( 2013-09-25 09:58:31 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-09-23 05:35:55 -0500

Arne gravatar image

This might happen, because you are running out of memory while compiling. Even though it works for the guy in the tutorial, that doesn't mean that the newer version of openCV you are using won't hit the magic point of exceeding the available memory. But you might try a newer version of your compiler or an older version of openCV. If that doesn't help you should consider cross-compiling it on your normal PC.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-09-22 11:16:00 -0500

Seen: 1,402 times

Last updated: Sep 23 '13