Is opencv 3.4 compatible with 2.4.3

asked 2019-04-04 14:42:31 -0500

smbika gravatar image

updated 2019-04-04 14:43:05 -0500

Our computers are by design offline and our ability to upgrade given our workload is limited, hence we are way behind. I need to do video capturing using H.264 RTSP stream over UDP sockets and it appears 3.4 or above is the version to use for that. The problem is we have a large C++ system (Windows .NET) with 2.4.3 intertwined throughout a quarter of a million lines of code. If I change our build to point to an installation of 3.4 will it break? Lots of IplImage references...:-(

edit retag flag offensive close merge delete

Comments

The answer is NO! It is not compatible.

supra56 gravatar imagesupra56 ( 2019-04-04 21:11:42 -0500 )edit

yea, that's "technical debt". IplImages were already deprecated in opencv2.0. you're stuck with outdated opencv versions forever.

berak gravatar imageberak ( 2019-04-05 01:46:20 -0500 )edit

Thanks!

I figured as much. And just as well. I may have to go the Emgu route and write what I need in C#. I find I don't have to build Emgu like it seems I have to with the C++ version. I find CMake pernitious so I won't be going down that rabbit hole on an offline machine (it gripes about not being able to download things).

I downloaded the binaries version with has 10 dlls and 4 libs (opencv_world...) but the build looks like it's for VS14 and VS15 - we're stuck with VS10 (don't ask - it's a mess).

So...we'll see.

Thanks again! Cheers

smbika gravatar imagesmbika ( 2019-04-05 12:50:45 -0500 )edit