Ask Your Question
1

Multiple E1083 on opencv-master compilation despite the correctness of path and rights

asked 2019-01-31 09:34:46 -0500

soleil gravatar image

updated 2019-01-31 10:09:20 -0500

I'm compiling opencv (master) in Windows 10 x64 with VS2017, toolset v141. VS projects are generated by cmake.

I'm having multiple errors such as:

c1xx : fatal error C1083: Cannot open source file: 'I:\opencv-master\opencv\3rdparty\openexr\IlmThread\IlmThreadWin32.cpp': No such file or directory [I:\opencv-master\build\3rdparty\openexr\IlmImf.vcxproj]

However, I don't understand how this could happen since:

the path is an absolute path,
the files do exist,
the right in read access are correct

I'm having this problem only with openexr project.

cmake -G $target -T v141, host=x64 -j8 `
    -DBUILD_JAVA=0 -DWITH_MATLAB=0 -DBUILD_DOC=0 -DBUILD_PERF_TESTS=0 -DBUILD_TESTS=0 -DBUILD_opencv_world=0 `
    -DOPENCV_ENABLE_NONFREE=1 -DBUILD_opencv-apps=0 -DENABLE_PYLINT=0 -DENABLE_CXX11=1 -DWITH_VTK=1 `
    -DCUDA_SDK_ROOT_DIR="$env:CUDA_PATH" -DCUDA_ARCH_BIN="5.2" -DCUDA_VERBOSE_BUILD=0 -DBUILD_CUDA_STUBS=0 `
    -DWITH_OPENCL=1 -DWITH_CUDA=1 -DMKL_WITH_OPENMP=1 -DMKL_WITH_TBB=1 `
    -DOPENCV_EXTRA_MODULES_PATH="../opencv_contrib/modules" `
    -DINSTALL_CREATE_DISTRIB=1 -DCPACK_BINARY_ZIP=1 -DCPACK_SOURCE_ZIP=1 -DCMAKE_VERBOSE_MAKEFILE=0 `
    ../opencv | Tee-Object -Variable RESULT

CMakeOutput.log:

The system is: Windows - 10.0.17134 - AMD64 Compiling the CXX compiler identification source file "CMakeCXXCompilerId.cpp" succeeded. Compiler:
Build flags: Id flags:

The output was: 0 Microsoft (R) Build Engine version 15.9.21+g9802d43bc3 for .NET Framework Copyright (C) Microsoft Corporation. All rights reserved.

Build started 30-Jan-19 8:43:38 PM. Project "I:\opencv-master\build\CMakeFiles\3.13.3\CompilerIdCXX\CompilerIdCXX.vcxproj" on node 1 (default targets). PrepareForBuild: Creating directory "Debug\". Creating directory "Debug\CompilerIdCXX.tlog\". InitializeBuildStatus: Creating "Debug\CompilerIdCXX.tlog\unsuccessfulbuild" because "AlwaysCreate" was specified. ClCompile: C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\VC\Tools\MSVC\14.16.27023\bin\HostX86\x64\CL.exe /c /nologo /W0 /WX- /diagnostics:classic /Od /D _MBCS /Gm- /EHsc /RTC1 /MDd /GS /fp:precise /Zc:wchar_t /Zc:forScope /Zc:inline /Fo"Debug\" /Fd"Debug\vc141.pdb" /Gd /TP /FC /errorReport:queue CMakeCXXCompilerId.cpp CMakeCXXCompilerId.cpp Link: C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\VC\Tools\MSVC\14.16.27023\bin\HostX86\x64\link.exe /ERRORREPORT:QUEUE /OUT:".\CompilerIdCXX.exe" /INCREMENTAL:NO /NOLOGO kernel32.lib user32.lib gdi32.lib winspool.lib comdlg32.lib advapi32.lib shell32.lib ole32.lib oleaut32.lib uuid.lib odbc32.lib odbccp32.lib /MANIFEST /MANIFESTUAC:"level='asInvoker' uiAccess='false'" /manifest:embed /PDB:".\CompilerIdCXX.pdb" /SUBSYSTEM:CONSOLE /TLBID:1 /DYNAMICBASE /NXCOMPAT /IMPLIB:".\CompilerIdCXX.lib" /MACHINE:X64 Debug\CMakeCXXCompilerId.obj CompilerIdCXX.vcxproj -> I:\opencv-master\build\CMakeFiles\3.13.3\CompilerIdCXX.\CompilerIdCXX.exe PostBuildEvent: for %%i in (cl.exe) do @echo CMAKE_CXX_COMPILER=%%~$PATH:i :VCEnd CMAKE_CXX_COMPILER=C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\VC\Tools\MSVC\14.16.27023\bin\Hostx86\x64\cl.exe FinalizeBuildStatus: Deleting file "Debug\CompilerIdCXX.tlog\unsuccessfulbuild". Touching "Debug\CompilerIdCXX.tlog\CompilerIdCXX.lastbuildstate". Done Building Project "I:\opencv-master\build\CMakeFiles\3.13.3\CompilerIdCXX\CompilerIdCXX.vcxproj" (default targets).

Build succeeded. 0 Warning(s) 0 Error(s)

Time Elapsed 00:00:00.42

Compilation of the CXX compiler identification source "CMakeCXXCompilerId.cpp" produced "CompilerIdCXX.exe"

Compilation of the CXX compiler identification source "CMakeCXXCompilerId.cpp" produced "CompilerIdCXX.vcxproj"

The CXX compiler identification is MSVC, found in "I ... (more)

edit retag flag offensive close merge delete

Comments

can you insert cmakeoutput.txt in your question?

LBerger gravatar imageLBerger ( 2019-01-31 09:56:29 -0500 )edit

it's not cmakeoutput.txt but cmakeoutput.log. you can find cmakeoutput in cmakegui window or when you call cmake -D... in a console window

LBerger gravatar imageLBerger ( 2019-01-31 10:41:54 -0500 )edit
1

I also made a diff with the vcxproj files (between git and zip), and they are identical

soleil gravatar imagesoleil ( 2019-01-31 15:48:03 -0500 )edit

clean your build folder and update https://github.com/mprevot/C1083/blob...

LBerger gravatar imageLBerger ( 2019-01-31 15:54:13 -0500 )edit

Did you mean build folder ?

soleil gravatar imagesoleil ( 2019-01-31 15:55:09 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
2

answered 2019-02-01 09:16:01 -0500

soleil gravatar image

updated 2019-02-03 08:00:57 -0500

I solved the issue even though I did not manage to find out the root problem. I had to do a git clone/pull with the visual studio distribution instead of the WSL (linux) git. I suspect there is a non-printable charater in cmakelist.txt that appeared after 4.0.0 since I did not have any problem before while using WSL git. Anyway, any hint to investigate further is welcome.

edit flag offensive delete link more
0

answered 2019-01-31 13:46:35 -0500

Hi, I have not encountered this problem myself, have you tried compiling OpenCV from a stable tag and not the tip of the master branch?

I found the latest version which works with CUDA without errors is 4.0.0. If you don't need anything which has been included since 4.0.0 I would try this first. I had no issues with the exact CMake configuration given here.

edit flag offensive delete link more

Comments

This is with master (from git). This does not happen with master (from zip). This started to happen between 4.0.0 and current 4.0.1 (I had no problem with master source from git pull for a while, then it appeared). I was having weekly build from master, and have no problem with my cmake configuration. Here, with cuda 10 and master (4.0.1), TBB, omp, multithread MKL (see my cmake config); It compiles fine completely (modulo a small patch that is being discuted in a pull request that allows to compile cuda parts).

soleil gravatar imagesoleil ( 2019-01-31 13:51:11 -0500 )edit

Hi, if this is a bug and not a build issue then I think you will get more help in response to the issue you logged on github.

cudawarped gravatar imagecudawarped ( 2019-01-31 14:08:03 -0500 )edit

@soleil really we have to guess everything? delete cmakecache.txt and give output of your cmake command. Without compiling you must get Configuring done Generating done

I cannot find any dependecies iin openexr about tbb mkl cuda...

LBerger gravatar imageLBerger ( 2019-01-31 14:24:40 -0500 )edit

alalek tagged the github issue as question: https://github.com/opencv/opencv/issu... Maybe this is a misunderstanding, maybe I was not clear.

soleil gravatar imagesoleil ( 2019-01-31 14:24:59 -0500 )edit

Is it possible to get your output ? something like this

LBerger gravatar imageLBerger ( 2019-01-31 14:29:31 -0500 )edit

@LBerger I'm not sure I understand by "guess". I put my cmake command in the OP. The dependencies you're mentionning are in the cmake command. I also gave the transcript of the ouput of cmake as github link as response to your comment asking for cmakeoutput.txt. cmake configuration and generation are both successful.

soleil gravatar imagesoleil ( 2019-01-31 14:29:40 -0500 )edit

@LBerger can you see the github link ?

soleil gravatar imagesoleil ( 2019-01-31 14:30:42 -0500 )edit

do you see this https://gist.github.com/LaurentBerger... ? Where can I find your cmake output in all your post and issue?

LBerger gravatar imageLBerger ( 2019-01-31 14:32:18 -0500 )edit
1

I see it twice. I'm posting again the link: https://github.com/mprevot/C1083/blob...

soleil gravatar imagesoleil ( 2019-01-31 14:34:41 -0500 )edit

Ok now I understand delete cmakecache and use only cmake -G $target -T v141 and see what happen

Lapack: NO

Parallel framework: Concurrency

LBerger gravatar imageLBerger ( 2019-01-31 14:45:18 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2019-01-31 09:33:59 -0500

Seen: 196 times

Last updated: Feb 03 '19