VideoCapture not working even in opencv

asked 2013-09-16 09:24:07 -0500

samkhan13 gravatar image

I installed opencv @ + python27 via macports on my mac os x 10.7.5 and the VideoCapture stopped working. Can any of you verify that the latest version of opencv with python27 on macports is working properly?

I've read all the discussions online about how opencv 2.4.6 had a bug in the video capture pipeline for linux machines and I've noticed how people have had to rebuild and reinstall python, numpy and opencv in the past week. Their problem seemed to have been resolved by rebuilding opencv with WITH_V4L=ON. But I am stuck because I have been using macports for various libraries and I dont want to go through the whole download>build>make>install routine for all my different libraries.

Please help.

edit retag flag offensive close merge delete


I'm having the same problem. I just went through the whole process of rebuilding opencv with WITH_V4L=ON but still getting the same error :(

Another thing is when I run by the default compiler which is (Apple LLVM compiler 4.2) on Xcode, I get linker errors but if I use LLVM GCC 4.2 it compiles but again the VideoCapture doesn't work anyway. I'd certainly appreciate any help and advice?

mel gravatar imagemel ( 2013-09-16 14:51:42 -0500 )edit

my solution was to install opencv 2.4.4 via macports.

samkhan13 gravatar imagesamkhan13 ( 2013-10-22 23:24:54 -0500 )edit