Ask Your Question
0

OpenCV 3.4.1 Cascade Classifier HOG

asked 2019-01-16 07:22:30 -0500

jay18395729 gravatar image

Hey,

i trained a HOG classifier and want to test it with my program, but i get the error message: Ex = {msg={cstr_=0x077ba804 "OpenCV(3.4.1) C:\Users\XXX\Downloads\opencv2\opencv_new\source\modules\objdetect\src\cascadedetect.cpp:1472: error: (-213) HOG cascade is not supported in 3.0 in function cv::CascadeClassifier... ...} ...}

Iam using OpenCV 3.4.1 and still get this error. Is it a known bug?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2019-01-16 07:28:31 -0500

berak gravatar image

support for the HOG cascades was removed in opencv3.0 already. (and it won't come back.)

you could either try to train a HogDetector from your data (would need cropped positives), or, if you want to use the current cascade, fall back to opencv2.4

edit flag offensive delete link more

Comments

1

Thank you for your response. I will try to build a HOG detector.

jay18395729 gravatar imagejay18395729 ( 2019-01-16 07:34:04 -0500 )edit
1

ow btw, hog cascades were broken, the feature generation was not identical to HogDetector and thus kind of training uncorrect models as far as I understood it.

StevenPuttemans gravatar imageStevenPuttemans ( 2019-01-16 08:59:18 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-01-16 07:22:30 -0500

Seen: 226 times

Last updated: Jan 16 '19