OpenCV with CUDA

asked 2018-12-06 04:07:10 -0500

Filippo9669 gravatar image

updated 2018-12-06 07:44:38 -0500

Hi there. I'm trying to run CUDA libraries with my OpenCV project (need for GpuMat). I've generated a solution with CMake (WITH_CUDA ON) and builded it (although it lasted 2.5h...), then created a new CUDA project and linked all the librares. Unfortunately, while compiling the code, I get an error:

Error: No CUDA support (The library is compiled without CUDA support) in throw_no_cuda, file E:\OPEN_CV\opencv-master\modules\core\include\opencv2/core/private.cuda.hpp, line 107

I've tried copying .dll and .lib files into my project directory and updating GF960m drivers but none of them worked out. Have you got any idea?

EDIT: this is my CMake output log. Windows 10 64bit OpenCV 3.4.1 Microsoft Visual Studio

edit retag flag offensive close merge delete


opencv / cuda version ? os ? compiler ?

do you still have the cmake output ? it might have some hints, if or what went wrong. (if so, please edit your question, and put it there)

berak gravatar imageberak ( 2018-12-06 07:01:21 -0500 )edit

I've added all required data.

Filippo9669 gravatar imageFilippo9669 ( 2018-12-06 07:43:59 -0500 )edit