OpenCV 3.2 Multitracker Read Access Violation

asked 2018-11-08 10:20:51 -0600

jay18395729 gravatar image


When i use the Multitracker, i get after 4-8 hours a Read Access Violation 0xC0000005 when the Tracker updates the Image. The Error happened at copyMakeBorder_u8 line 1070. I checked that the Image is not a nullpointer when i call Tracker->update(Image). Maybe someone has a solution for me.

edit retag flag offensive close merge delete


3.2 did not have "debug guards", so chances are, that you accidentally linked opencv debug libs to a release project (or the other way round)

can you take a (sharp !) look at your project's linker settings ?

then, it's probably a good idea to update booth of opencv and opencv_contrib to latest 3.4 branch,

-- 3-2-0 is 2 years old !

berak gravatar imageberak ( 2018-11-08 10:24:27 -0600 )edit

Hey, thank you for you Response. I checked the linker Settings, but i didnt see any debug libs in my release Project. I also checked the pointers at copyMakeBorder_u8 again and the src Pointer is Null and the dst Pointer ist not Null.

I thought OpenCV 3.2 is a good choice because i used it before and had no Problems with it. So you suggest to use 3.4 now?

jay18395729 gravatar imagejay18395729 ( 2018-11-08 10:53:00 -0600 )edit

idk. but there have been tons of changes to the "low level" stuff in the meantime. maybe just give it a try ?

berak gravatar imageberak ( 2018-11-08 10:55:34 -0600 )edit

I Change the build now to Version 3.4. The Problem is, that the error just show up after a few hours and so it is hard to find the reason. I will write again, after i tested it with the new Version.

jay18395729 gravatar imagejay18395729 ( 2018-11-08 11:03:00 -0600 )edit

yes, please do so ;)

if you can nail a bug, it has to be reported, so it can be repaired, no ?

berak gravatar imageberak ( 2018-11-08 11:09:54 -0600 )edit

if you use opencv_contrib libs, you MUST NOT link opencv_world (from the old, prebuilt libs) !

berak gravatar imageberak ( 2018-11-09 07:47:07 -0600 )edit

Ok, i did not linked it.My program is running since 9AM and it did not crash until now. I hope the error is solved. Thanik you for your help. If i still get that error, i try to comment here again.

jay18395729 gravatar imagejay18395729 ( 2018-11-09 11:53:52 -0600 )edit