Ask Your Question
0

OpenCV 4.0: class “cv::FastFeatureDetector” has no member “DetectorType” [closed]

asked 2018-10-13 03:12:56 -0500

I tried to build OpenCV 4.0 using opencv_contrib and it didn't work.

xfeatures2d.hpp has the following line, and the error is in

cv::FastFeatureDetector::DetectorType

CV_EXPORTS void FASTForPointSet( InputArray image, CV_IN_OUT std::vector<KeyPoint>& keypoints,
                  int threshold, bool nonmaxSuppression=true, cv::FastFeatureDetector::DetectorType type=FastFeatureDetector::TYPE_9_16);

I checked inside FasFeatureDetector and its parent, and the class really hasn't a definition for DetectorType.

I'm posting here to see if anyone else had this error, or if it's a bug with using OpenCV 4.0-alpha with opencv_contrib. If anyone can help, thank you.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Marcloure
close date 2018-10-13 04:23:48.636237

Comments

os, compiler ? (c++11 related problem ?)

berak gravatar imageberak ( 2018-10-13 03:57:14 -0500 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2018-10-13 04:23:15 -0500

It seems that this enum was, for whatever reason, unnamed. Naming it as DetectorType solved my problem.

I really don't know why the enum wasn't originally named, but someone else had the same error. The link below leads to a Page Not Found, but someone else did ask the same question (and probably deleted the post after solving it).

https://stackoverflow.com/questions/5...

Thank you.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2018-10-13 03:12:56 -0500

Seen: 815 times

Last updated: Oct 13 '18