Compile Opencv 3.4.3 ( windows )with CUDA Toolkit 10.0...can't found CUDA_SDK_ROOT_DIR

asked 2018-09-28 09:12:04 -0500

adrsanna gravatar image

updated 2018-09-28 12:42:57 -0500

Hello, I tried different solution without any success... I have:

  • Windows 10 Platform
  • Visual Studio 2017 v.15.3.5
  • Opencv 3.4.3 source
  • Cmake GUI v.3.10
  • CUDA Toolkit 10.0 cuda hardware (laptop - Nvidia GTX960M 2GB)

When I tried to configure 'WITH CUDA' (using Visual Studio 15 Generator), I retrive the same error:

"CMake Warning at cmake/OpenCVFindLibsPerf.cmake:42 (message): OpenCV is not able to find/configure CUDA SDK (required by WITH_CUDA). CUDA support will be disabled in OpenCV build. To eliminate this warning remove WITH_CUDA=ON CMake configuration option. Call Stack (most recent call first): CMakeLists.txt:629 (include)"

I test with the Nvida Toolkit DeviceQuery.exe and all seems fine on the hardware side... P.S.: Without Cuda it compiles without errors.

any suggestions?

Thanks in advance

Adriano

edit retag flag offensive close merge delete