Ask Your Question
0

Problem with Haar Cascade Training [closed]

asked 2018-07-30 07:36:49 -0500

nicoz gravatar image

I'm following the tutorial for a haar cascade training (https://docs.opencv.org/3.4.1/dc/d88/...). I'm trying to execute the createsamples.cpp from opencv_createsamples, but I always get this error:‘class cv::AutoBuffer<short int="">’ has no member named ‘data’, does anyone have an idea of what problem could be?</short>

I've looked here https://docs.opencv.org/3.1.0/d8/dd0/..., and actually there's no public member named data, should I replace "data" with which member?

Thanks in advance!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by nicoz
close date 2018-07-31 09:45:52.714945

Comments

which opencv version is it ?

berak gravatar imageberak ( 2018-07-30 09:09:21 -0500 )edit

OpenCV 3.4.1

nicoz gravatar imagenicoz ( 2018-07-30 09:11:47 -0500 )edit

yes, the data member was added later. but the opencv_createsamples from your 3.4.1 version should, work, so there's some weird version mismatch here.

berak gravatar imageberak ( 2018-07-30 09:29:32 -0500 )edit

there is no datain the 3.4.1 version

so just use the correct program for your opencv version.

berak gravatar imageberak ( 2018-07-30 09:35:48 -0500 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2018-07-30 12:13:44 -0500

nicoz gravatar image

Now I know what was going wrong. I didn't pay attention that this apps come automatically when OpenCV is installed, so I was trying to create a project in codeblocks with the files from an older version of these OpenCV apps. I've made a big mess, but now that's ok. Thanks for helping me!

edit flag offensive delete link more

Comments

oooook. ;)

berak gravatar imageberak ( 2018-07-30 12:27:25 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2018-07-30 07:36:49 -0500

Seen: 69 times

Last updated: Jul 30 '18