Ask Your Question

OpenCV CMake Error

asked 2018-04-15 16:34:08 -0500

Imago gravatar image

I am currently setting up opencv and qtcreator, so I can use them together. For this, I am following the suggested instructions on stackoverflow, can be found here.

In step 6.5 I run however into the following problem: CMake shows me the error:

CMake Error at cmake/OpenCVUtils.cmake:813 (if):
  if given arguments:

    "NOT" "item" "MATCHES"   "C:/Users/Me/Desktop/opencv/sources/modules/core/include"

  Regular expression
  cannot compile
Call Stack (most recent call first):
  modules/python/bindings/CMakeLists.txt:23 (ocv_list_filter)

Does someone know, what casues this error and how to fix it?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2018-04-25 08:32:00 -0500

It seems like it's an error within OpenCV and "regular expression" suggests it's an issue with their string parsing using reg exp. I'd suggest trying to install the latest version of CMake, checking your cmake error logs - which will be shown in your console (or gui console). This will prompt you towards what the error might be, although they can be fairly roundabout as to what the actual issue might be!

Basically, with their regular expression finder, it seems like there are a number of special characters i.e. + ' / etc. which it fails to handle.

edit flag offensive delete link more


I can confirm that I get a similar problem when I tried to build opencv in a directory structure containing "C++". It worked fine when placed elsewhere.

MikeTronix gravatar imageMikeTronix ( 2018-11-09 13:38:46 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2018-04-15 16:33:18 -0500

Seen: 179 times

Last updated: Apr 15 '18