Ask Your Question

Getting error for MobileNet SSD Dnn model.

asked 2018-02-28 09:00:01 -0500

vps gravatar image

updated 2018-03-01 06:50:07 -0500

Hi, I am posting this question once again with more details. I tried all possible things but did not get success. As suggestion from @sturkmen. I have use below files. It will be great , if you tell me the soultion on this.

1) link text 2) MobileNetSSD_deploy.caffemodel 3) MobileNetSSD_deploy.prototxt

Command Arguments: onceMoreDnn.exe -video=cat.jpg -opencl -model=MobileNetSSD_deploy.caffemodel -proto=MobileNetSSD_deploy.prototxt

Error: C:\Users\Shejal\Documents\Visual Studio 2015\Projects\onceMoreDnn\x64\Debug>once MoreDnn.exe [libprotobuf ERROR C:\build\master_winpack-build-win64-vc14\opencv\3rdparty\prot obuf\src\google\protobuf\] Error parsing text-format opencv_ca ffe.NetParameter: 7:1: Expected identifier, got: < OpenCV Error: Unspecified error (FAILED: ReadProtoFromTextFile(param_file, param ). Failed to parse NetParameter file: MobileNetSSD_deploy.prototxt) in cv::dnn:: ReadNetParamsFromTextFileOrDie, file C:\build\master_winpack-build-win64-vc14\op encv\modules\dnn\src\caffe\caffe_io.cpp, line 1145

old question link :link text System Config: Windows7, opencv 3.4image description

edit retag flag offensive close merge delete


my file size :

28/02/2018  16:42        23 147 564 MobileNetSSD_deploy.caffemodel
28/02/2018  16:47            31 265 mobileNetSSD_deploy.prototxt



LBerger gravatar imageLBerger ( 2018-02-28 09:51:22 -0500 )edit

@LBerger, I have updated above files. Still, Same error.

vps gravatar imagevps ( 2018-02-28 10:01:05 -0500 )edit

can you post only the first ten line of mobileNetSSD_deploy.prototxt?

LBerger gravatar imageLBerger ( 2018-02-28 10:04:53 -0500 )edit

i think it is time to update your OpenCV version to 3.4.1

sturkmen gravatar imagesturkmen ( 2018-02-28 10:15:03 -0500 )edit

like @sturkmen mentioned, DNN is under heavy improvement, so keep up with latest codebase ;)

StevenPuttemans gravatar imageStevenPuttemans ( 2018-02-28 12:09:54 -0500 )edit

1 answer

Sort by » oldest newest most voted

answered 2018-03-01 06:53:08 -0500

vps gravatar image

Intially, I was using wrong protoxt file. After that, I have updated correct file. Still , I was getting error. At last, I have installed opencv 3.4.1 version and it is working. Thanks @sturkmen for suggestion.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2018-02-28 09:00:01 -0500

Seen: 1,374 times

Last updated: Mar 01 '18