.lib files missing?

asked 2013-08-09 06:12:22 -0500

Basha gravatar image

updated 2013-08-09 10:26:53 -0500

Hello, I am totally new to OpenCV and I have currently troubles with making it work with Code::Blocks.

I was using this tutorial, using manually configuring option: http://opencv.willowgarage.com/wiki/CodeBlocks#manually

Everything was fine, until step: "5. Now click on "Linker Settings". Add all the .lib files from "C:\OpenCV\build\x86\mingw\lib" (many files). This will let you project link to OpenCV libraries: "

I have opened the directory ...\OpenCV\build\x86\mingw\lib and it contains no .lib files.

I used newest OpenCV installation file(OpenCV-2.4.6.0.exe); Windows 7 x86; Code::Blocks 12.11

UPDATE: I tried adding the .a files instead and it seemed to link the libraries correctly, but now I am getting different, really weird error (set of similar errors):

My_File_Location...\opencv\build\include\opencv2\core\operations.hpp|3918|error: expected primary-expression before '>' token|

What does it mean? The program itself should not be faulty (it is a sample code, more precisely ffilldemo.cpp) and the library part itself should also be ok (i didn't manipulate with it at all).

Any new ideas? Did I fail something terribly during configuration? Why I just can't get anything right on first few tries...

Any help greatly appreciated.

edit retag flag offensive close merge delete

Comments

but there are .a files ? add those instead ( btw, that tut is old and full of errors )

berak gravatar imageberak ( 2013-08-09 08:23:55 -0500 )edit

Yeah, you are right about how old it is... Now I tried adding the .a files ant it helped, but a new error appeared. See update. (and many thanks for your advice )

Basha gravatar imageBasha ( 2013-08-09 10:31:20 -0500 )edit

any chance, you're compiling with gcc instead of g++ ? or any other option, that tries to compile it as c instead of c++ ..

berak gravatar imageberak ( 2013-08-09 10:39:01 -0500 )edit

In the menu that opens when creating new project in Code::Blocks I chose C++ option and GNU GCC compiler. It compiles simple hello world using iostream without problems, so it should handle the program as c++.

Basha gravatar imageBasha ( 2013-08-09 10:50:58 -0500 )edit

k, just asking .. no idea atm

berak gravatar imageberak ( 2013-08-09 11:00:31 -0500 )edit

Looks like I finally made it!!! :) As it turned out my version of MinGW had some nasty bug, so reinstalling new version of it solved the problem :) thank you for your time

Basha gravatar imageBasha ( 2013-08-09 12:34:02 -0500 )edit

hey, cool ;) can you just edit your question, and add something like [solved] to the title ?

berak gravatar imageberak ( 2013-08-09 12:51:20 -0500 )edit