Ask Your Question
0

Opencv_Contrib Module Ximgproc

asked 2018-01-18 10:18:45 -0500

dursunsefa gravatar image

I installed Opencv_Contrib module in Visual Studio with Cmake. I'm trying to compile the "fourier_descriptors_demo.cpp".. But for ximgroc module I get an error like :

namespace "cv:ximgproc" has no member "ContourFitting"

namespace "cv:ximgproc" has no member "contourSampling" etc.

How can I fix this error?

Thank you for helping.

edit retag flag offensive close merge delete

Comments

if you update opencv_contrib you must delete cmakecache.txt.

LBerger gravatar imageLBerger ( 2018-01-18 10:21:56 -0500 )edit

which opencv version is it ?

berak gravatar imageberak ( 2018-01-18 10:32:03 -0500 )edit

@LBerger I deleted this , but I get the same error again. I think there is another problem here.

dursunsefa gravatar imagedursunsefa ( 2018-01-18 10:38:18 -0500 )edit

@berak Opencv 3.2.0

dursunsefa gravatar imagedursunsefa ( 2018-01-18 10:40:06 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
2

answered 2018-01-18 10:45:40 -0500

berak gravatar image

updated 2018-01-18 10:47:18 -0500

opencv3.2.0 does not have this functionality, it was added in 3.4.0

please:

  • download latest master branch of BOTH opencv and opencv_contrib
  • clean your build folder
  • restart with cmake
edit flag offensive delete link more

Comments

1

I will try this. Thank you very much for helping

dursunsefa gravatar imagedursunsefa ( 2018-01-18 10:52:02 -0500 )edit

pleasure. if you run into further trouble -- we're here ;)

berak gravatar imageberak ( 2018-01-18 10:53:27 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2018-01-18 10:18:45 -0500

Seen: 586 times

Last updated: Jan 18 '18