GStreamer unable to open RTSP stream on CentOS OpenCV

asked 2017-11-30 01:45:22 -0500

BAHRAMUDIN ADIL gravatar image

I am trying to open RTSP video stream using GStreamer on Linux CentOS, it throws the exception below:

OpenCV Error: Unspecified error (GStreamer: your gstreamer installation is missing a required plugin

I have tried all possible ways

  1. People suggested solutions on the internet
  2. Installed all the packages which belong to GStreamer (base, good, bad, ugly, with and without dev)
  3. Installed all versions of GStreamer (0.10 and 1.0)
  4. At the end, deeply installed both 0.10 and 1.0 by using command (yum install gstreamer*, and gstreamer1*)

But no one has solved the problem.

Note: While building OpenCV from source, everything installed successfully, and CMake was able to find all the GStreamer and FFmpeg packages on the System, the value of CMake output was all YES for both GStreamer and its plugins and FFmpeg and its plugins. So OpenCV was installed successfully.

OpenCV 3.3.1

edit retag flag offensive close merge delete