install opencv3 to codeblocks "missing libintl-8.dll" [closed]

asked 2017-11-25 18:19:27 -0500

updated 2017-11-25 20:16:37 -0500

Tetragramm gravatar image

hi im trying to install opencv3 to codeblocks but get "missing libintl-8.dll" i spent all day yesterday searching for a way to fix or install libintl8 but no difinitive answer any one have clue how to fix this

windows 10 and according to how long it took to prove I'm not a freaking robot just to post a question they don't really want anyone to post ffs.

edit retag flag offensive reopen merge delete

Closed for the following reason question is off-topic or not relevant by berak
close date 2017-11-27 04:03:41.202487

Comments

since you don't mention it, -- codeblocks usually comes with gcc, and the prebuild opencv libs are for vs2015 only. so, step1 would be to use cmake to build opencv libs locally. did you do that ?

berak gravatar imageberak ( 2017-11-25 20:37:53 -0500 )edit

yes I downloaded cmake and tried several of the ways that google said but still "missing libntl-8.dll"

imnobode gravatar imageimnobode ( 2017-11-26 03:51:57 -0500 )edit

that's a mingw related dll, so probably your mingw/bin folder is not on the PATH

berak gravatar imageberak ( 2017-11-26 04:18:54 -0500 )edit

yes but I couldn't find a way to put it on the path

imnobode gravatar imageimnobode ( 2017-11-26 05:00:54 -0500 )edit

I misspoke there were ways to do it but they were "just add path_this\that\theother" and I have no idea where to add those

imnobode gravatar imageimnobode ( 2017-11-26 05:06:53 -0500 )edit

system settings -> extended -> environment

add a semicolon, and the (complete) path to mingw/bin to the PATH variable

berak gravatar imageberak ( 2017-11-26 05:24:08 -0500 )edit

okay but still not understanding I've got win 10, codeblocks 16.01 migw32x64. if your talking about sys setting on computer I don't have "environment" . if your talking about code blocks, after "settings-environment" ive got a bunch of check boxes to enable disable and two spaces,"shell to run in" and "terminal to launch console program"

imnobode gravatar imageimnobode ( 2017-11-26 05:49:22 -0500 )edit

okay I had run cmake the day before and after file explorer to search mingw/bin in codeblocks found this "cmakecache.txt" and only that. inside that I found //Configs CMAKE_CONFIGURATION_TYPES:STRING=Debug;Release

//CXX compiler CMAKE_CXX_COMPILER:FILEPATH=C:/Program Files (x86)/CodeBlocks/MinGW/bin/g++.exe

//Installation Directory CMAKE_INSTALL_PREFIX:PATH=C:/opencv/opencv/New_build/install

//make program CMAKE_MAKE_PROGRAM:FILEPATH=C:/PROGRA~2/CODEBL~1/MinGW/bin/mingw32-make.exe

//Value Computed by CMake CMAKE_PROJECT_NAME:STATIC=OpenCV

//Path to a program. CMAKE_SH:FILEPATH=CMAKE_SH-NOTFOUND

//Value Computed by CMake OpenCV_BINARY_DIR:STATIC=C:/opencv/opencv/New_build

//Value Computed by CMake OpenCV_SOURCE_DIR:STATIC=C:/opencv/opencv/sources

#

INTERNAL

imnobode gravatar imageimnobode ( 2017-11-26 06:27:04 -0500 )edit

its the" //path to a program cmake_sh:filepath=cmake_sh-not found" that interests me. you think if I change that to the path it might work?. ill try it tomorrow but now night night sleep tight don't let the bed bugs bite

imnobode gravatar imageimnobode ( 2017-11-26 06:30:43 -0500 )edit

let's close this. it is all about installing / using codeblocks correctly, and not at all about opencv.

berak gravatar imageberak ( 2017-11-27 04:03:27 -0500 )edit