Ask Your Question
0

Cannot import "ccalib" module from opencv-contrib

asked 2017-09-15 14:23:57 -0500

the_parzival gravatar image

Hi, I compiled opencv from source by including opencv-contrib modules. I can import almost all the modules, except ccalib module which is used to calibrate the camera using custom calibration pattern. I even compiled examples too, they are working and i can run all the examples in ccalib module. I can even find the concerned module in modules folder of build directory. I cannot import it after i run make install. I will be grateful if someone points out what i am doing wrong?

edit retag flag offensive close merge delete

Comments

" I cannot import it after i run make install" -- what does that mean, exactly ? error msgs ?

berak gravatar imageberak ( 2017-09-16 04:49:12 -0500 )edit

I m using python wrappers for OpenCV, when i try to import the module, it says there is no attribute called ccalib for cv2.

the_parzival gravatar imagethe_parzival ( 2017-09-16 10:46:44 -0500 )edit

hey, that's an important detail !

berak gravatar imageberak ( 2017-09-16 11:06:15 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-09-16 11:13:50 -0500

berak gravatar image

you might just be out of luck here. only the cv::omnidir functions are wrapped into python

(anything else is only available from c++)

please check:

help(cv2.omnidir)
edit flag offensive delete link more

Comments

Thanks for clarification,then i will use C++.

the_parzival gravatar imagethe_parzival ( 2017-09-16 11:25:40 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-09-15 14:23:57 -0500

Seen: 128 times

Last updated: Sep 16 '17