Ask Your Question
0

compile opencv_contrib with 2.4.13.3 [closed]

asked 2017-09-12 01:37:57 -0500

cbyzju gravatar image

Hi, I try to add the support of opencv_contrib, when I compile 2.4.13.3, but I meet some problems, I wonder it's possible to compile opencv_contrib with 2.x, or just 3.x is the only right version. Thank you!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by cbyzju
close date 2017-09-12 02:53:18.192063

2 answers

Sort by ยป oldest newest most voted
0

answered 2017-09-12 01:44:32 -0500

berak gravatar image

no, unfortunately this is NOT possible.

you will need latest master branch (3.3 currently) of both opencv and opencv_contrib repos.

edit flag offensive delete link more

Comments

1

yeah, thank you very much. I have found the answer, when I try to compile it, opencv_contrib needs a lot of functions which are only available in opencv 3.x branch.

cbyzju gravatar imagecbyzju ( 2017-09-12 02:52:50 -0500 )edit
0

answered 2017-09-12 01:43:27 -0500

LBerger gravatar image

It is written in opencv_contrib :

How to build OpenCV with extra modules

You can build OpenCV, so it will include the modules from this repository. Contrib modules are under constant development and it is recommended to use them alongside the master branch or latest releases of OpenCV.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-09-12 01:37:57 -0500

Seen: 92 times

Last updated: Sep 12 '17