Building OpenCV2.4.6 using CMake gui PrimeSense

asked 2017-08-14 19:40:33 -0500

JSVueCo gravatar image

updated 2017-08-15 18:19:52 -0500

I understand that version 246 is old but I need this specific version for a Unity asset that is set at a specific version that uses these files.

Is there any way to find primesense it seems to be one of the last programs I need to complete the OpenCV 2.4.6 Build in cmake gui.I tried download from the Git repo but the won't run in CMD. I get "Import Error : No module named win32con". Any help would be greatly appreciated thanks.

Edit: I should add I also tried to simply run the exe setup file in the primesense folders and it does not work.

edit retag flag offensive close merge delete


Hi sturkmen, I have the source code the problem is trying to build it I am running into the issues above. I need primesense, I have tried to install primesense using the exe file in the folders from the primesense repo on Git. The setup file does not seem to work neither does running the in CMD.

JSVueCo gravatar imageJSVueCo ( 2017-08-15 18:18:40 -0500 )edit

do you need dlls running in windows?

sturkmen gravatar imagesturkmen ( 2017-08-15 18:28:47 -0500 )edit

i can't test but teorically you can use 2.4.13 dlls by renaming file names. you can try to download 2.4.13 binaries from here

for example rename opencv_core2413.dll ->opencv_core246.dll and so on
sturkmen gravatar imagesturkmen ( 2017-08-15 18:49:26 -0500 )edit

Yes this is for windows. Is it that simple from 2.4.13? I say this because I have tried to rename 2.4.10 and that did not work.

JSVueCo gravatar imageJSVueCo ( 2017-08-17 18:56:56 -0500 )edit

the 2 files that I tried to rename btw are opencv_core and opencv_flann

JSVueCo gravatar imageJSVueCo ( 2017-08-17 18:58:54 -0500 )edit

did you get any error message?

sturkmen gravatar imagesturkmen ( 2017-08-17 19:04:09 -0500 )edit

have not tried to rename 2.4.13 i will try today. As far as renaming 2.4.10 there are no error messages specifically for these files. I am using it with Unity3D for an asset. The asset just does not work and the error says can not find ARWrapper.dll which from my understanding is the error you get when you are missing opencv_core and flann of version 2.4.6.

JSVueCo gravatar imageJSVueCo ( 2017-08-18 12:46:16 -0500 )edit

do you have ARWrapper.dll ?

sturkmen gravatar imagesturkmen ( 2017-08-18 13:02:05 -0500 )edit

Yes that dll is in the proper folder. The asset is called ARToolkit. Everywhere I have looked points to these files. I guess it makes sense since they are nonexistent on my computer.

JSVueCo gravatar imageJSVueCo ( 2017-08-18 13:17:00 -0500 )edit

I have also tried to rename the files today, and unfortunately that does not work either.

JSVueCo gravatar imageJSVueCo ( 2017-08-18 19:40:00 -0500 )edit